aboutsummaryrefslogtreecommitdiffstats
path: root/community/lximage-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lximage-qt/APKBUILD')
-rw-r--r--community/lximage-qt/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/lximage-qt/APKBUILD b/community/lximage-qt/APKBUILD
new file mode 100644
index 00000000000..52969513fc4
--- /dev/null
+++ b/community/lximage-qt/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=lximage-qt
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="The image viewer and screenshot tool for LXQt"
+url="https://github.com/lxqt/lximage-qt"
+arch="all !armhf !s390x" # armhf blocked by liblxqt, s390x blocked by libfm-qt
+license="LGPL-2.0-or-later"
+makedepends="
+ cmake samurai lxqt-build-tools liblxqt-dev qt5-qttools-dev
+ libfm-qt-dev libexif-dev menu-cache-dev
+ "
+options="!check" # No testsuite
+subpackages="$pkgname-lang"
+source="https://github.com/lxqt/lximage-qt/releases/download/$pkgver/lximage-qt-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+
+lang() {
+ install_if="lang $pkgname=$pkgver-r$pkgrel"
+ amove usr/share/$pkgname/translations
+}
+
+sha512sums="
+c0dea9418890745de685c7df228ceb849fa21781764c2089481bea89526842e5e8f0972e032ba9c52b07c32202ed284d977f47ace598c44880dff661d76cd125 lximage-qt-1.4.0.tar.xz
+"