aboutsummaryrefslogtreecommitdiffstats
path: root/community/lxqt-about/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lxqt-about/APKBUILD')
-rw-r--r--community/lxqt-about/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/lxqt-about/APKBUILD b/community/lxqt-about/APKBUILD
new file mode 100644
index 00000000000..566802166fd
--- /dev/null
+++ b/community/lxqt-about/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=lxqt-about
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Information provider about LXQt and the system"
+url="https://github.com/lxqt/lxqt-about"
+arch="all !armhf" # armhf blocked by liblxqt and kwindowsystem
+license="LGPL-2.0-or-later"
+makedepends="
+ cmake samurai lxqt-build-tools liblxqt-dev
+ kwindowsystem5-dev qt5-qttools-dev
+ "
+subpackages="$pkgname-lang"
+options="!check" # No testsuite
+source="https://github.com/lxqt/lxqt-about/releases/download/$pkgver/lxqt-about-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+
+lang() {
+ install_if="lang $pkgname=$pkgver-r$pkgrel"
+ amove usr/share/lxqt/translations/$pkgname
+}
+
+sha512sums="
+308ffc83d8d9a1b835670cb3ea97b97859922bbd9026d1b8b7bd98949030e42bf96a4dcb6363f24d00fd75733c436e4dbfe29e37b4b8c6cda07460ac1ec05241 lxqt-about-1.4.0.tar.xz
+"