aboutsummaryrefslogtreecommitdiffstats
path: root/community/lxqt-archiver/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lxqt-archiver/APKBUILD')
-rw-r--r--community/lxqt-archiver/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/lxqt-archiver/APKBUILD b/community/lxqt-archiver/APKBUILD
new file mode 100644
index 00000000000..29e886418e0
--- /dev/null
+++ b/community/lxqt-archiver/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=lxqt-archiver
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Simple and lightweight desktop-agnostic Qt file archiver"
+url="https://github.com/lxqt/lxqt-archiver"
+arch="all !armhf"
+license="LGPL-2.0-or-later"
+depends="tar"
+makedepends="
+ cmake samurai lxqt-build-tools qt5-qttools-dev qt5-qtx11extras-dev
+ libfm-qt-dev json-glib-dev menu-cache-dev libexif-dev
+ "
+options="!check" # No testsuite
+subpackages="$pkgname-lang"
+source="https://github.com/lxqt/lxqt-archiver/releases/download/$pkgver/lxqt-archiver-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+
+lang() {
+ install_if="lang $pkgname=$pkgver-r$pkgrel"
+ amove usr/share/$pkgname/translations
+}
+
+sha512sums="
+42ee097ae7fb17dbd00d9b94e8673664911c73bb5f353d08177c78d548eb24c39aa1daf57347eeefcb46ec63a8702c37f63ca2b42fd22bc85aed8f7a41585f3c lxqt-archiver-0.9.0.tar.xz
+"