aboutsummaryrefslogtreecommitdiffstats
path: root/community/lxqt-desktop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lxqt-desktop/APKBUILD')
-rw-r--r--community/lxqt-desktop/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/lxqt-desktop/APKBUILD b/community/lxqt-desktop/APKBUILD
new file mode 100644
index 00000000000..6c2b5860965
--- /dev/null
+++ b/community/lxqt-desktop/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=lxqt-desktop
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="LXQt Desktop"
+url="https://lxqt-project.org/"
+# armhf: blocked by liblxqt
+# s390x: blocked by lxqt-runner
+arch="noarch !armhf !s390x"
+license="GPL-3.0-or-later"
+options="!check" # No testsuite
+replaces="lxqt-core"
+provides="lxqt-core=$pkgver-r$pkgrel"
+depends="
+ libqtxdg libsysstat liblxqt libfm-qt lxqt-themes
+ libdbusmenu-qt lxqt-about lxqt-admin lxqt-config
+ lxqt-globalkeys lxqt-powermanagement lxqt-session
+ lxqt-panel lxqt-runner pcmanfm-qt xscreensaver
+ lxqt-qtplugin lxqt-notificationd lxqt-archiver
+ lxqt-policykit lxqt-openssh-askpass lxqt-sudo
+ pm-utils qtermwidget qterminal openbox xdg-utils
+ "
+
+package() {
+ mkdir -p "$pkgdir"
+}