aboutsummaryrefslogtreecommitdiffstats
path: root/community/lxqt-sudo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lxqt-sudo/APKBUILD')
-rw-r--r--community/lxqt-sudo/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/lxqt-sudo/APKBUILD b/community/lxqt-sudo/APKBUILD
new file mode 100644
index 00000000000..82fe4059a29
--- /dev/null
+++ b/community/lxqt-sudo/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=lxqt-sudo
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Tools to sudoure LXQt and the underlying operating system"
+url="https://github.com/lxqt/lxqt-sudo"
+arch="all !armhf" # blocked by liblxqt-dev
+license="LGPL-2.0-or-later"
+makedepends="
+ cmake samurai libxcursor-dev lxqt-build-tools qt5-qtbase-dev
+ qt5-qttools-dev qt5-qtx11extras-dev xf86-input-libinput-dev
+ libxi-dev eudev-dev libqtxdg-dev liblxqt-dev
+ libkscreen-dev kwindowsystem5-dev
+ "
+subpackages="$pkgname-doc $pkgname-lang"
+options="!check" # No testsuite
+source="https://github.com/lxqt/lxqt-sudo/releases/download/$pkgver/lxqt-sudo-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+
+lang() {
+ install_if="lang $pkgname=$pkgver-r$pkgrel"
+ amove usr/share/lxqt/translations/$pkgname
+}
+
+sha512sums="
+0f9eda1ae4272410b18fdce1059702715c1f8ea3d75893a00d18890b713cd0269a727f95e95959a3156d998447770b666119b068c2d1af9686938fb03a59e16e lxqt-sudo-1.4.0.tar.xz
+"