aboutsummaryrefslogtreecommitdiffstats
path: root/community/macchanger/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/macchanger/APKBUILD')
-rw-r--r--community/macchanger/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/community/macchanger/APKBUILD b/community/macchanger/APKBUILD
index ea06b123909..3e286ce9f24 100644
--- a/community/macchanger/APKBUILD
+++ b/community/macchanger/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=macchanger
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="An utility for viewing/manipulating the MAC address of network interfaces"
url="https://github.com/alobbs/macchanger"
arch="all"
@@ -12,10 +12,8 @@ makedepends="linux-headers"
subpackages="$pkgname-doc"
source="https://github.com/alobbs/macchanger/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
fix-caddr_t.patch"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -26,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
./src/macchanger --help > /dev/null
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}