aboutsummaryrefslogtreecommitdiffstats
path: root/community/mapbox-gl-qml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mapbox-gl-qml/APKBUILD')
-rw-r--r--community/mapbox-gl-qml/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/mapbox-gl-qml/APKBUILD b/community/mapbox-gl-qml/APKBUILD
index 76ef2c71282..eabae004c38 100644
--- a/community/mapbox-gl-qml/APKBUILD
+++ b/community/mapbox-gl-qml/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=mapbox-gl-qml
-pkgver=1.7.6
+pkgver=2.1.1
pkgrel=0
pkgdesc="QML bindings for Mapbox"
url="https://github.com/rinigus/mapbox-gl-qml"
@@ -10,17 +10,18 @@ arch="all !armhf"
license="LGPL-3.0-only"
makedepends="
cmake
- mapbox-gl-native-dev
+ maplibre-gl-native-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtlocation-dev
+ qt5-qtsvg-dev
"
source="https://github.com/rinigus/mapbox-gl-qml/archive/$pkgver/mapbox-gl-qml-$pkgver.tar.gz"
options="!check" # No tests
build() {
cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DUSE_CURL_SSL=OFF
@@ -31,4 +32,6 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="2c6b21d0793cbe2aaed4ba8c2d44f661807c398ff0f4705f1b2b214124b9937d3aace021f03f7447b9e567ed45163502fdff98f9a7e1ade33b9ed61b75e736fe mapbox-gl-qml-1.7.6.tar.gz"
+sha512sums="
+a755089a63b5dd76c1520a138aaac7bb80f051adc9ce8eefa22141bdd6b9c2786a075426cdeaaa2650185d69a5aadeb591b83ada2fbae053345a6ec02826f804 mapbox-gl-qml-2.1.1.tar.gz
+"