aboutsummaryrefslogtreecommitdiffstats
path: root/community/marco/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/marco/APKBUILD')
-rw-r--r--community/marco/APKBUILD36
1 files changed, 27 insertions, 9 deletions
diff --git a/community/marco/APKBUILD b/community/marco/APKBUILD
index f0209fdab31..695ac052639 100644
--- a/community/marco/APKBUILD
+++ b/community/marco/APKBUILD
@@ -1,18 +1,35 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
pkgname=marco
-pkgver=1.26.0
-pkgrel=0
+pkgver=1.26.2
+pkgrel=1
pkgdesc="MATE window manager"
url="https://github.com/mate-desktop/marco"
-# s390x, mips64 and riscv64 are blocked by librsvg -> mate-desktop
-arch="all !s390x !mips64 !riscv64"
+arch="all"
license="GPL-2.0-or-later"
-depends="mate-common yelp-tools libxml2-utils mate-desktop"
-makedepends="libtool itstool zenity intltool glib-dev gtk+3.0-dev
- libxcomposite-dev libxpresent-dev libcanberra-dev startup-notification-dev"
+depends="
+ libxml2-utils
+ mate-common
+ mate-desktop
+ yelp-tools
+ "
+makedepends="
+ glib-dev
+ gtk+3.0-dev
+ intltool
+ itstool
+ libcanberra-dev
+ libtool
+ libxcomposite-dev
+ libxpresent-dev
+ libxres-dev
+ startup-notification-dev
+ zenity
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://pub.mate-desktop.org/releases/${pkgver%.*}/marco-$pkgver.tar.xz"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/marco-$pkgver.tar.xz
+ startup-notification-long.patch
+ "
build() {
./configure \
@@ -34,5 +51,6 @@ package() {
}
sha512sums="
-013ba12dc7f4affe24bc5763ae88e44ede3f1454e74b5a642503d3741ce935f6757eba3f9def56670414c5a9c03b38384b5b54a494f9cb8f5bfd480e43300e76 marco-1.26.0.tar.xz
+326ed378be891806a9750021626863e00d80f29af8fe920eeb0910d9eb2ece534babf012e1aced6b071b6c0fdd8a77ea8c948d68a70f9280822b30231aa934b9 marco-1.26.2.tar.xz
+ad5a84871c4fb16bb27f840cdee1ccf73a018e76c8d729a03e6c0eb424f6c4f7cc9a32216b27a73cae200813daae08a103faac4aeac62b112e443774540a6e63 startup-notification-long.patch
"