aboutsummaryrefslogtreecommitdiffstats
path: root/community/marco/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/marco/APKBUILD')
-rw-r--r--community/marco/APKBUILD37
1 files changed, 29 insertions, 8 deletions
diff --git a/community/marco/APKBUILD b/community/marco/APKBUILD
index 1eb96ea107f..695ac052639 100644
--- a/community/marco/APKBUILD
+++ b/community/marco/APKBUILD
@@ -1,17 +1,35 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
pkgname=marco
-pkgver=1.24.0
-pkgrel=0
+pkgver=1.26.2
+pkgrel=1
pkgdesc="MATE window manager"
url="https://github.com/mate-desktop/marco"
-arch="all !s390x !mips !mips64" # Limited by mate-desktop
+arch="all"
license="GPL-2.0-or-later"
-depends="mate-common yelp-tools libxml2-utils mate-desktop"
-makedepends="libtool itstool zenity intltool glib-dev gtk+3.0-dev
- libxcomposite-dev libxpresent-dev libcanberra-dev startup-notification-dev"
+depends="
+ libxml2-utils
+ mate-common
+ mate-desktop
+ yelp-tools
+ "
+makedepends="
+ glib-dev
+ gtk+3.0-dev
+ intltool
+ itstool
+ libcanberra-dev
+ libtool
+ libxcomposite-dev
+ libxpresent-dev
+ libxres-dev
+ startup-notification-dev
+ zenity
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://pub.mate-desktop.org/releases/${pkgver%.*}/marco-$pkgver.tar.xz"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/marco-$pkgver.tar.xz
+ startup-notification-long.patch
+ "
build() {
./configure \
@@ -32,4 +50,7 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="b257994c097f174fe83f3f0f4d6b6991e8c0f402daffd99f8a9521d588b609c56953e73dd4d143be64f5c9a4caa8d890ff30a120e18a9d5b36c6f856a7190428 marco-1.24.0.tar.xz"
+sha512sums="
+326ed378be891806a9750021626863e00d80f29af8fe920eeb0910d9eb2ece534babf012e1aced6b071b6c0fdd8a77ea8c948d68a70f9280822b30231aa934b9 marco-1.26.2.tar.xz
+ad5a84871c4fb16bb27f840cdee1ccf73a018e76c8d729a03e6c0eb424f6c4f7cc9a32216b27a73cae200813daae08a103faac4aeac62b112e443774540a6e63 startup-notification-long.patch
+"