aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-calc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mate-calc/APKBUILD')
-rw-r--r--community/mate-calc/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/community/mate-calc/APKBUILD b/community/mate-calc/APKBUILD
index aa310c65a5b..93cee44792e 100644
--- a/community/mate-calc/APKBUILD
+++ b/community/mate-calc/APKBUILD
@@ -1,18 +1,23 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=mate-calc
-pkgver=1.24.2
-pkgrel=0
+pkgver=1.26.0
+pkgrel=2
pkgdesc="Calculator for MATE"
url="https://github.com/mate-desktop/mate-calc"
arch="all"
license="GPL-2.0-or-later"
depends="mate-common"
makedepends="itstool libtool intltool gtk+3.0-dev
- libxml2-utils libxml2-dev"
+ libxml2-utils libxml2-dev mpfr-dev mpc1-dev gmp-dev"
subpackages="$pkgname-lang $pkgname-doc"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/mate-calc-$pkgver.tar.xz"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
@@ -30,4 +35,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="d790aefd2839237d6776c6b0508ded53d6eef52456a3025f08bcaf826f8c56754e079d50703a4f7f834f5167f802ddb3d7b95ece613e00faf3ad6f5c1d402e97 mate-calc-1.24.2.tar.xz"
+sha512sums="
+142c496f8fcf1180f28e02b6a5d6d31ff00b7751783415c7d18e4086e316ca7d23ed0da0f9ecc0705773eb5e01f21e639f15d475aa1da1a7b5b03742ba45cb2f mate-calc-1.26.0.tar.xz
+"