aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-indicator-applet/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mate-indicator-applet/APKBUILD')
-rw-r--r--community/mate-indicator-applet/APKBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/community/mate-indicator-applet/APKBUILD b/community/mate-indicator-applet/APKBUILD
index 791871871fc..21bdbcd928d 100644
--- a/community/mate-indicator-applet/APKBUILD
+++ b/community/mate-indicator-applet/APKBUILD
@@ -1,23 +1,30 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=mate-indicator-applet
-pkgver=1.24.0
-pkgrel=0
+pkgver=1.26.0
+pkgrel=1
pkgdesc="A small applet to display information from various applications consistently in the panel"
url="https://github.com/mate-desktop/mate-indicator-applet"
-arch="all !s390x !mips !mips64" # mate-panel -> mate-desktop
+arch="all"
license="GPL-3.0-or-later AND LGPL-2.1-or-later"
-makedepends="autoconf automake libtool mate-common glib-dev
- gtk+3.0-dev mate-panel-dev intltool libindicator-dev"
+makedepends="
+ autoconf
+ autoconf-archive
+ automake
+ glib-dev
+ gtk+3.0-dev
+ intltool
+ libayatana-indicator-dev
+ libido3-dev
+ libtool
+ mate-common
+ mate-panel-dev
+ "
subpackages="$pkgname-lang"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/mate-indicator-applet-$pkgver.tar.xz"
-prepare() {
- default_prepare
- NOCONFIGURE=1 ./autogen.sh
-}
-
build() {
+ NOCONFIGURE=1 ./autogen.sh
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -37,4 +44,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="0e82f572c1855c8623e537a45c2c0c0b98d3d642e46333eedc16c26607205293098a062008d0e568890ffdf6b8dc4c30a7f5e2e41a150f940917b3671783e413 mate-indicator-applet-1.24.0.tar.xz"
+sha512sums="
+677586b4090edd22871eb034b923795a01030a5270e633a11ed711171e49f487047fbf75daf1d69d491660bdf63421b900e06fd806eeef93df101058c0130c06 mate-indicator-applet-1.26.0.tar.xz
+"