aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-panel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mate-panel/APKBUILD')
-rw-r--r--community/mate-panel/APKBUILD31
1 files changed, 23 insertions, 8 deletions
diff --git a/community/mate-panel/APKBUILD b/community/mate-panel/APKBUILD
index 38f5ced52f1..f4d286a11a2 100644
--- a/community/mate-panel/APKBUILD
+++ b/community/mate-panel/APKBUILD
@@ -1,16 +1,29 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
pkgname=mate-panel
-pkgver=1.24.1
-pkgrel=0
+pkgver=1.27.2
+pkgrel=1
pkgdesc="The MATE panel is the area on your desktop from which you can run applications"
url="https://github.com/mate-desktop/mate-panel"
-arch="all !s390x !mips !mips64" # mate-desktop
+arch="all"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
-depends="mate-common mate-desktop"
-makedepends="librsvg-dev libmateweather-dev libtool intltool itstool
- mate-menus-dev dconf-dev libice-dev libsm-dev libcanberra-dev dbus-glib-dev
- libwnck3-dev libsoup-dev mate-desktop-dev libxml2-utils"
+depends="dconf-editor mate-common" # added dconf-editor due to issue #15428
+makedepends="
+ dbus-glib-dev
+ dconf-dev
+ intltool
+ itstool
+ libcanberra-dev
+ libice-dev
+ libmateweather-dev
+ librsvg-dev
+ libsm-dev
+ libtool
+ libwnck3-dev
+ libxml2-utils
+ mate-desktop-dev
+ mate-menus-dev
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/mate-panel-$pkgver.tar.xz"
@@ -32,4 +45,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1a1e62207d58472daa00d409ef2b04944929af7f9fe05592076adcc069e2d70012424b3386d30f8b9adccf05c328b8ab1662b8726e507465881a4ae26c26829f mate-panel-1.24.1.tar.xz"
+sha512sums="
+93431af5ffd1241c5fb56dd0a60eeba2de89e745502575cfd8f281700345689edc50ec653a6d9b1472a6d0e9d7d09a7e1439627fcacfdc627f187551cef21b6f mate-panel-1.27.2.tar.xz
+"