aboutsummaryrefslogtreecommitdiffstats
path: root/community/mauikit-texteditor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mauikit-texteditor/APKBUILD')
-rw-r--r--community/mauikit-texteditor/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/community/mauikit-texteditor/APKBUILD b/community/mauikit-texteditor/APKBUILD
index 9c321f6fb91..afd1079b41d 100644
--- a/community/mauikit-texteditor/APKBUILD
+++ b/community/mauikit-texteditor/APKBUILD
@@ -1,43 +1,48 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
pkgname=mauikit-texteditor
-pkgver=2.1.0
+pkgver=3.0.2
pkgrel=0
pkgdesc="MauiKit Text Editor components"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by mauikit
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://mauikit.org/"
license="GPL-2.0-or-later"
depends="kirigami2"
makedepends="
extra-cmake-modules
- kcoreaddons-dev
- ki18n-dev
- syntax-highlighting-dev
+ kcoreaddons5-dev
+ ki18n5-dev
+ syntax-highlighting5-dev
mauikit
mauikit-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
"
+subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/maui/mauikit-texteditor.git"
source="https://download.kde.org/stable/maui/mauikit-texteditor/$pkgver/mauikit-texteditor-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-12ddad633e3e89dfdd05b194e4b3e35100063b074dc42fbb9f9cb415a7513658b5a9bef95ec7bd2cd7e60491f11ef9e855ddd71ebabe6b7bda5cec8193a24850 mauikit-texteditor-2.1.0.tar.xz
+12b53717d41fd91affca1217c6ee90742170ca4794b86ddca60e942652796d8c79c65ab8458d9b27b91e1eb94032f23ff146906ee20f06dd9d5dea1c097ebf51 mauikit-texteditor-3.0.2.tar.xz
"