aboutsummaryrefslogtreecommitdiffstats
path: root/community/mblaze/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mblaze/APKBUILD')
-rw-r--r--community/mblaze/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/mblaze/APKBUILD b/community/mblaze/APKBUILD
index d7c627d7fd8..0791e05ad71 100644
--- a/community/mblaze/APKBUILD
+++ b/community/mblaze/APKBUILD
@@ -1,37 +1,38 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=mblaze
-pkgver=1.1
-pkgrel=1
+pkgver=1.2
+pkgrel=2
pkgdesc="Unix utilities to deal with Maildir"
-url="https://github.com/chneukirchen/mblaze"
+url="https://github.com/leahneukirchen/mblaze"
arch="all"
license="CC0-1.0"
depends="file"
checkdepends="perl-utils"
subpackages="$pkgname-doc $pkgname-crypto::noarch"
-options="!check" # currently fail on the builder
-source="$pkgname-$pkgver.tar.gz::https://github.com/chneukirchen/mblaze/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/leahneukirchen/mblaze/archive/v$pkgver.tar.gz
+ mlist.patch
+ "
build() {
- make CFLAGS="$CFLAGS" -C "$builddir"
+ make CFLAGS="$CFLAGS"
}
check() {
- make -C "$builddir" check
+ make check
}
package() {
make PREFIX="/usr" DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples/
- install -m644 *.example "$pkgdir"/usr/share/doc/$pkgname/examples/
+ install -m644 ./*.example "$pkgdir"/usr/share/doc/$pkgname/examples/
install -m644 NEWS.md VIOLATIONS.md README \
"$pkgdir"/usr/share/doc/$pkgname/
}
crypto() {
- depends="openssl gnupg"
+ depends="openssl gpg"
pkgdesc="Scripts for using S/MIME and PGP"
cd "$builddir/contrib"
@@ -40,4 +41,7 @@ crypto() {
"$subpkgdir"/usr/bin
}
-sha512sums="c74bcfa8675a6461a820e2d421712ed3be1d0d2ac80f8ef99d4e2812b67a387c50ad5fdc14a43accaec149dbab831ad2af43db4f6ba575724f30d92e6281cd3e mblaze-1.1.tar.gz"
+sha512sums="
+32f1ed6332d3b481d501e6f4f64fbd9b74ac26aabf55862da8b2444144e9a39f908143c3ec77b0adce90f08455e7544af9f19458d4e628c36c06ee407d81548a mblaze-1.2.tar.gz
+882cebb308209ffeb4e10ddd7c5a61ed13e8c22fa42d6a437e347aa1b095718fee17f87f3bbedffb43b9ac8bdf422c8acd9b2bc9bf18bf836abeb513cb106509 mlist.patch
+"