aboutsummaryrefslogtreecommitdiffstats
path: root/community/mdds/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mdds/APKBUILD')
-rw-r--r--community/mdds/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/mdds/APKBUILD b/community/mdds/APKBUILD
new file mode 100644
index 00000000000..e605a5d5205
--- /dev/null
+++ b/community/mdds/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=mdds
+pkgver=0.12.1
+pkgrel=0
+pkgdesc="Multi-dimentional data index algorithm"
+url="https://code.google.com/p/multidimalgorithm/"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://kohei.us/files/$pkgname/src/${pkgname}_$pkgver.tar.bz2
+ "
+
+_builddir="$srcdir"/${pkgname}_$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -d 755 "$pkgdir"/usr/lib
+ mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib/
+}
+
+md5sums="ef2560ed5416652a7fe195305b14cebe mdds_0.12.1.tar.bz2"
+sha256sums="23565e9d7810a6ac30478833813db847f80e927b414a7be07b7cc03ed3aae83d mdds_0.12.1.tar.bz2"
+sha512sums="852f58e1f3c18aef78646c2bd6b34dc544fc06cba7ef6bda2a44fd5e681bf47bbf7389505061ddd81797b0bdf343e55f060397a1ccc582c73990bc74d36575a6 mdds_0.12.1.tar.bz2"