aboutsummaryrefslogtreecommitdiffstats
path: root/community/mdds/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mdds/APKBUILD')
-rw-r--r--community/mdds/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/community/mdds/APKBUILD b/community/mdds/APKBUILD
index ad47bcf5cc6..82b83a3d444 100644
--- a/community/mdds/APKBUILD
+++ b/community/mdds/APKBUILD
@@ -1,17 +1,21 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=mdds
-pkgver=1.4.3
+pkgver=2.1.1
pkgrel=1
pkgdesc="Multi-dimensional data index algorithm"
url="https://gitlab.com/mdds/mdds"
arch="noarch"
license="MIT"
-makedepends="$depends_dev"
-checkdepends="boost-dev"
+makedepends="autoconf automake boost-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://kohei.us/files/mdds/src/mdds-$pkgver.tar.bz2
- "
+source="https://gitlab.com/mdds/mdds/-/archive/$pkgver/mdds-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+
+ NOCONFIGURE=1 ./autogen.sh
+}
build() {
./configure \
@@ -35,4 +39,6 @@ package() {
mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib/
}
-sha512sums="fd54a93fde89bff74a5ccf84ce5e2e002114297b165ded56a1bae92b28d70864775add140e165c7750f7dbe8ca1bfe83179cd9a835e53312c2e893c9e1f4434c mdds-1.4.3.tar.bz2"
+sha512sums="
+211e33479faa1208be29b96b147119d92f64ac04649d3c85b7f0974493977ede26ea69f189a559fcb3be56238ba1cd42587e95c04c0ac65619fb56d4808d3309 mdds-2.1.1.tar.gz
+"