aboutsummaryrefslogtreecommitdiffstats
path: root/community/mdds
diff options
context:
space:
mode:
Diffstat (limited to 'community/mdds')
-rw-r--r--community/mdds/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/community/mdds/APKBUILD b/community/mdds/APKBUILD
index e605a5d5205..2ba8b5f2f38 100644
--- a/community/mdds/APKBUILD
+++ b/community/mdds/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=mdds
-pkgver=0.12.1
+pkgver=1.2.1
pkgrel=0
pkgdesc="Multi-dimentional data index algorithm"
url="https://code.google.com/p/multidimalgorithm/"
@@ -12,13 +12,13 @@ depends_dev=""
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://kohei.us/files/$pkgname/src/${pkgname}_$pkgver.tar.bz2
+source="http://kohei.us/files/mdds/src/mdds-$pkgver.tar.bz2
"
-_builddir="$srcdir"/${pkgname}_$pkgver
+builddir="$srcdir"/${pkgname}-$pkgver
prepare() {
local i
- cd "$_builddir"
+ cd "$builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -27,7 +27,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -41,12 +41,12 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
install -d 755 "$pkgdir"/usr/lib
mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib/
}
-md5sums="ef2560ed5416652a7fe195305b14cebe mdds_0.12.1.tar.bz2"
-sha256sums="23565e9d7810a6ac30478833813db847f80e927b414a7be07b7cc03ed3aae83d mdds_0.12.1.tar.bz2"
-sha512sums="852f58e1f3c18aef78646c2bd6b34dc544fc06cba7ef6bda2a44fd5e681bf47bbf7389505061ddd81797b0bdf343e55f060397a1ccc582c73990bc74d36575a6 mdds_0.12.1.tar.bz2"
+md5sums="4cf64cd1f6543501b10054a0801a03dd mdds-1.2.1.tar.bz2"
+sha256sums="1e2f49dfc7b9d444bad07064837099741f4c2d061807173392ad2357116dfc7b mdds-1.2.1.tar.bz2"
+sha512sums="c865e1f6f55ce2d7a590dee55d374f252606f2c10dcb966b21249f20e248d87c22cd72b652548ce88ac9e5562d249c531a7f2a44c37ee17cc84ec2708c89591b mdds-1.2.1.tar.bz2"