aboutsummaryrefslogtreecommitdiffstats
path: root/community/menu-cache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/menu-cache/APKBUILD')
-rw-r--r--community/menu-cache/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/community/menu-cache/APKBUILD b/community/menu-cache/APKBUILD
index 366b80262f1..eeef7c1d35e 100644
--- a/community/menu-cache/APKBUILD
+++ b/community/menu-cache/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-
pkgname=menu-cache
pkgver=1.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="Caching mechanism for freedesktop.org compliant menus"
arch="all"
license="GPL-2.0+"
@@ -11,9 +10,17 @@ url="https://lxde.org/"
makedepends="glib-dev libfm-extra-dev"
options="!check libtool" # No test suite.
source="https://downloads.sourceforge.net/lxde/menu-cache-$pkgver.tar.xz
- menu-cache-1.1.0-0001-Support-gcc10-compilation.patch"
+ menu-cache-1.1.0-0001-Support-gcc10-compilation.patch
+ "
subpackages="$pkgname-dev"
+prepare() {
+ default_prepare
+
+ update_config_sub
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \