aboutsummaryrefslogtreecommitdiffstats
path: root/community/mercury/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mercury/APKBUILD')
-rw-r--r--community/mercury/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/mercury/APKBUILD b/community/mercury/APKBUILD
index 1eb95d4b985..787bc67d203 100644
--- a/community/mercury/APKBUILD
+++ b/community/mercury/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Clayton Craft <clayton@craftyguy.net>
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=mercury
-pkgver=22.01.2
-pkgrel=0
+pkgver=22.01.8
+pkgrel=1
pkgdesc="Compiler for the Mercury language"
-url="http://www.mercurylang.org"
-arch="all !riscv64" # hangs on configure tests
+url="https://www.mercurylang.org"
+arch="all"
license="GPL-2.0-only"
makedepends="autoconf automake bison flex"
depends="$pkgname-libs"
subpackages="$pkgname-doc $pkgname-libs"
source="
- http://dl.mercurylang.org/release/mercury-srcdist-$pkgver.tar.gz
+ https://dl.mercurylang.org/release/mercury-srcdist-$pkgver.tar.gz
0001-disable-gcc-label-support-on-arm.patch
0002-always-build-shared-libs.patch
"
@@ -19,16 +19,21 @@ options="!check" # tests are unstable / flaky
builddir="$srcdir"/mercury-srcdist-"$pkgver"
build() {
- ./configure \
+ # TODO: The configure check for GCC labels causes a bug in qemu
+ # on riscv64. Need to create a minimal example and report that
+ # upstream. As a workaround, just skip the check by hardcoding
+ # the result.
+ mercury_cv_gcc_labels=yes ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--enable-shared-libs \
+ --with-llds-base-grade=fast \
--enable-libgrades="hlc.gc"
- make PARALLEL="$MAKEFLAGS"
+ make PARALLEL="-j${JOBS:-1}"
}
package() {
@@ -38,7 +43,7 @@ package() {
INSTALL_INFO_DIR="$pkgdir"/usr/share/info \
MERCURY_COMPILER="$pkgdir"/usr/bin/mercury_compile \
MERCURY_CONFIG_DIR="$pkgdir"/usr/lib/mercury \
- PARALLEL="$MAKEFLAGS" \
+ PARALLEL="-j${JOBS:-1}" \
install
rm "$pkgdir"/usr/lib/mercury/lib/hlc.gc/libmer_*.a
@@ -54,7 +59,7 @@ libs() {
}
sha512sums="
-7a7abeee4e34be62eadc65657c03670885d47b8ee4feb8eef110664761912c95cdb0a82880167cbd6977bed6f0e952c7f91cf2e42e7449183a4f73bfb5db4b69 mercury-srcdist-22.01.2.tar.gz
+7a3f40c8876bec059842d133b50be9c19d60739ba320ce5f0df160b2e3473077f4394e794a45e23d35f4088dc04f23a24c8f6e0f724bbcf4b3822e15e5d3bf72 mercury-srcdist-22.01.8.tar.gz
57af805aa1a4bb7e7b471ffd5c2311138385ec76107568a0f7846e50922a8aca7604889be1f181b86fb5b04f68225bb588184746962757a1d3b59133d9280b0a 0001-disable-gcc-label-support-on-arm.patch
e8c546928d4872d386a754e9d5289939577b32ed16a9f2e0b3cce5b36cd3aeee113265d2435188ab9bbc7f57bd355ea7dc9837be935b877488d44f5e67783332 0002-always-build-shared-libs.patch
"