aboutsummaryrefslogtreecommitdiffstats
path: root/community/milou/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/milou/APKBUILD')
-rw-r--r--community/milou/APKBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/community/milou/APKBUILD b/community/milou/APKBUILD
index e36e901dfd1..4d371f033e0 100644
--- a/community/milou/APKBUILD
+++ b/community/milou/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=milou
-pkgver=5.22.5
+pkgver=6.0.4
pkgrel=0
pkgdesc="A dedicated search application built on top of Baloo"
-# armhf blocked by qt5-qtdeclarative
-# s390x blocked by polkit -> kdeclarative
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
makedepends="
@@ -17,34 +19,36 @@ makedepends="
kitemmodels-dev
krunner-dev
kservice-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
"
case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/milou-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/milou.git"
+source="https://download.kde.org/stable/plasma/$pkgver/milou-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-9be952458c3e5c6b0cf99fde2c6dd810f109af5c6c1fecf0419b615ebeaf5c2794301ed7d96e234a4b111fb8e5d63e11e9848f7112bc16580fda7ef107b81d60 milou-5.22.5.tar.xz
+8a95186eb0933236f03e846d8cc2ab886882e44a13de98de4aefdd915955f5f3f7d4fb0c358449869324dd7deca772c78172c90a2203828e30e9c39fb70d8c71 milou-6.0.4.tar.xz
"