aboutsummaryrefslogtreecommitdiffstats
path: root/community/milou/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/milou/APKBUILD')
-rw-r--r--community/milou/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/milou/APKBUILD b/community/milou/APKBUILD
index 6260c627f59..b9920c2a66d 100644
--- a/community/milou/APKBUILD
+++ b/community/milou/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=milou
pkgver=5.24.4
-pkgrel=0
+pkgrel=1
pkgdesc="A dedicated search application built on top of Baloo"
# armhf blocked by qt5-qtdeclarative
# s390x blocked by polkit -> kdeclarative
@@ -20,6 +20,7 @@ makedepends="
plasma-framework-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
"
case "$pkgver" in
@@ -30,8 +31,8 @@ source="https://download.kde.org/$_rel/plasma/$pkgver/milou-$pkgver.tar.xz"
subpackages="$pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -45,6 +46,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
ef41d274970e38f45e26bc986948e3ba49d0ef54a907e64fc36f15ed9369d3c4cd5e2566b25a2d3499b123cb0ec20eca9c777ab3a66248e6a5a824d7b7c4ae96 milou-5.24.4.tar.xz
"