aboutsummaryrefslogtreecommitdiffstats
path: root/community/minetest
diff options
context:
space:
mode:
Diffstat (limited to 'community/minetest')
-rw-r--r--community/minetest/0001-CMake-link-with-Intl-when-necessary.patch50
-rw-r--r--community/minetest/APKBUILD21
2 files changed, 9 insertions, 62 deletions
diff --git a/community/minetest/0001-CMake-link-with-Intl-when-necessary.patch b/community/minetest/0001-CMake-link-with-Intl-when-necessary.patch
deleted file mode 100644
index d24f8c9509f..00000000000
--- a/community/minetest/0001-CMake-link-with-Intl-when-necessary.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 45ed3aa6be6d70cf76a4f10c81684ab86cb5017f Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@gmail.com>
-Date: Mon, 12 Jun 2017 21:57:05 +0200
-Subject: [PATCH] CMake: link with Intl when necessary
-
-On non Glibc system linking with Intl library may be needed when
-Gettext support is enabled.
-
-Fixes:
-clientlauncher.cpp:(.text+0xcac): undefined reference to `libintl_gettext'
-clientlauncher.cpp:(.text+0xdf0): undefined reference to `libintl_gettext'
-
-Signed-off-by: Romain Naour <romain.naour@gmail.com>
----
- src/CMakeLists.txt | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -70,6 +70,14 @@ if(ENABLE_GETTEXT)
- endif()
- set(USE_GETTEXT TRUE)
- message(STATUS "GetText enabled; locales found: ${GETTEXT_AVAILABLE_LOCALES}")
-+ # On some platforms, such as Linux with GNU libc, the gettext
-+ # functions are present in the C standard library and libintl
-+ # is not required. For other libc (uClibc-ng or musl) libintl
-+ # may be required.
-+ find_package(Intl)
-+ if(NOT Intl_LIBRARIES STREQUAL "")
-+ message(STATUS "GetText Intl : ${Intl_LIBRARIES}")
-+ endif()
- endif(GETTEXTLIB_FOUND)
- else()
- mark_as_advanced(GETTEXT_ICONV_DLL GETTEXT_INCLUDE_DIR GETTEXT_LIBRARY GETTEXT_MSGFMT)
-@@ -554,6 +554,7 @@
- ${BZIP2_LIBRARIES}
- ${PNG_LIBRARIES}
- ${X11_LIBRARIES}
-+ ${Intl_LIBRARIES}
- ${SOUND_LIBRARIES}
- ${SQLITE3_LIBRARY}
- ${LUA_LIBRARY}
-@@ -623,6 +624,7 @@
- ${ZLIB_LIBRARIES}
- ${SQLITE3_LIBRARY}
- ${JSON_LIBRARY}
-+ ${Intl_LIBRARIES}
- ${LUA_LIBRARY}
- ${GMP_LIBRARY}
- ${PLATFORM_LIBS}
diff --git a/community/minetest/APKBUILD b/community/minetest/APKBUILD
index ef82e1c155a..5c1673e3b49 100644
--- a/community/minetest/APKBUILD
+++ b/community/minetest/APKBUILD
@@ -3,12 +3,12 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=minetest
-pkgver=5.6.0
-pkgrel=0
+pkgver=5.8.0
+pkgrel=1
pkgdesc="An infinite-world block sandbox game and a game engine"
url="https://www.minetest.net/"
-# riscv64 blocked by luajit
-arch="all !riscv64"
+# ppc64le, riscv64 blocked by luajit
+arch="all !ppc64le !riscv64"
license="LGPL-2.1-or-later AND CC-BY-SA-3.0"
pkgusers="minetest"
pkggroups="minetest"
@@ -40,12 +40,11 @@ subpackages="$pkgname-doc
$pkgname-server
$pkgname-server-openrc:openrc
"
-_irrlichtver="1.9.0mt7"
+_irrlichtver="1.9.0mt13"
source="https://github.com/minetest/minetest/archive/refs/tags/$pkgver/minetest-$pkgver.tar.gz
https://github.com/minetest/irrlicht/archive/refs/tags/$_irrlichtver/irrlichtmt-$_irrlichtver.tar.gz
minetest-server.confd
minetest-server.initd
- 0001-CMake-link-with-Intl-when-necessary.patch
"
prepare() {
@@ -92,8 +91,7 @@ common() {
install -o minetest -g minetest -d "$subpkgdir"/var/lib/minetest
amove \
- usr/share/minetest/builtin \
- usr/share/minetest/games
+ usr/share/minetest/builtin
}
server() {
@@ -109,7 +107,7 @@ server() {
openrc() {
pkgdesc="Minetest server (OpenRC init scripts)"
- install_if="$pkgname-server openrc"
+ install_if="$pkgname-server=$pkgver-r$pkgrel openrc"
install -Dm755 "$srcdir"/minetest-server.initd \
"$subpkgdir"/etc/init.d/minetest-server
@@ -118,9 +116,8 @@ openrc() {
}
sha512sums="
-e87c4036f17a61d3e623b2f48e3611ba1bc0177b5d58330fe6e64a74075c78ab7cd5eb7b855097ce98819112a54857324237f7d3b81ec504a1f608444e74a630 minetest-5.6.0.tar.gz
-5b533efde6bca5ff2a6041d88fcf405c3452c0ccc52ca2d5e03072b0b31c16830cf5fe2af06573c71b29022b590f3082fc8997537c73a7e1981911083e7bf855 irrlichtmt-1.9.0mt7.tar.gz
+0b376ecc051032ccb542f2f76e2b1f5c351b32f1c211027825b1538095f44cb1447cd0976cb85a4cde4ecb53873bcb9f3778799271ed65b038a031dc137c2aba minetest-5.8.0.tar.gz
+5226d78eaacf8b56eafbbb6359bfb6137f9d6a555a252224e33d39c0d219fcb7d0d29fd3828961eee37d55940f3aa6e767fea31c96fb772dd5eca3889f5ac16e irrlichtmt-1.9.0mt13.tar.gz
7bca17dc0bd59db9c07c160677498aa09297026104e922bf93b7629c274d0aebd226af60c5e82f49ffe3cc5c1e4448e3798b6c2a44144fc6eca4d3aaed3384bb minetest-server.confd
c27aea87468538b48b5e0a66fa5cdde4fc67f3c00a0e57f359a2f044a31c5617d1b5f3dec72e015537ee3bf126bd1073878c0f4447de67db9be2c4cf21416dd7 minetest-server.initd
-c815e6c9c5433e4fda9b8559b662086e18b14461e4fd8626b4d5178554a2423c9b243450845d49710825b627dede91de8411655adff7a960672c639735499533 0001-CMake-link-with-Intl-when-necessary.patch
"