aboutsummaryrefslogtreecommitdiffstats
path: root/community/mingetty/fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/mingetty/fix-makefile.patch')
-rw-r--r--community/mingetty/fix-makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/mingetty/fix-makefile.patch b/community/mingetty/fix-makefile.patch
new file mode 100644
index 00000000000..36c6b461f13
--- /dev/null
+++ b/community/mingetty/fix-makefile.patch
@@ -0,0 +1,27 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,17 +1,20 @@
+ DESTDIR=
+ CC=gcc
+-CFLAGS=-O2 -Wall -W -pipe -D_GNU_SOURCE
++CFLAGS_ALL=$(CFLAGS) -Wall -W -pipe -D_GNU_SOURCE
+ MANDIR=/usr/share/man/man8
+ SBINDIR=/sbin
+
+ all: mingetty
+
+ install: all
+- install -m 0755 mingetty $(DESTDIR)$(SBINDIR)
+- install -m 0644 mingetty.8 $(DESTDIR)$(MANDIR)
++ install -D -m 0755 mingetty -t $(DESTDIR)$(SBINDIR)
++ install -D -m 0644 mingetty.8 -t $(DESTDIR)$(MANDIR)
+
+ mingetty: mingetty.o
++ $(CC) $(CFLAGS_ALL) $(LDFLAGS) -o $@ $< $(LDLIBS)
+
++%.o: %.c
++ $(CC) $(CFLAGS_ALL) -c -o $@ $<
++
+ clean:
+ rm -f *.o mingetty
+-