aboutsummaryrefslogtreecommitdiffstats
path: root/community/miniupnpc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/miniupnpc/APKBUILD')
-rw-r--r--community/miniupnpc/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/community/miniupnpc/APKBUILD b/community/miniupnpc/APKBUILD
index 10605eee760..a81ffadf849 100644
--- a/community/miniupnpc/APKBUILD
+++ b/community/miniupnpc/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=miniupnpc
-pkgver=2.2.3
-pkgrel=0
+pkgver=2.2.5
+pkgrel=1
pkgdesc="Library and tool to control NAT in UPnP-enabled routers"
url="http://miniupnp.free.fr"
arch="all"
license="BSD-3-Clause"
makedepends="bsd-compat-headers py3-setuptools python3-dev"
subpackages="$pkgname-dev py3-$pkgname:_py3 $pkgname-doc"
-source="http://miniupnp.free.fr/files/miniupnpc-$pkgver.tar.gz
-fix-makefile-install.patch"
+source="http://miniupnp.free.fr/files/miniupnpc-$pkgver.tar.gz"
build() {
make
@@ -23,16 +22,15 @@ check() {
package() {
make DESTDIR="$pkgdir" PREFIX=/usr install
+ python3 setup.py install --skip-build --root="$pkgdir"
}
_py3() {
pkgdesc="Python bindings for miniupnpc"
- depends="python3"
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$subpkgdir" --skip-build
+
+ amove usr/lib/python3*
}
sha512sums="
-8b9555d336d5dfe8017a16727f964cddacb3f2bf3528fe3dd2416480da5763b24e1740345e470f2123c170d79d88444e41dbbce4536e6069590925e4805bc5ee miniupnpc-2.2.3.tar.gz
-ebc7df039cf36ac52d7712a610950c53fd926ae2bc949d2b62799ac5542fad004c5ea125b807178abc920143a90e57ac151a1f69768298fb892632990785e56b fix-makefile-install.patch
+32d362c43cf5c9f6c1546d85c2dd780f9701f3137bc78471b3670c4c0862b7fc4f081e6cb6fd14e5c0d3ec0602714756959491688998335c8a7b324e6c53aa2f miniupnpc-2.2.5.tar.gz
"