aboutsummaryrefslogtreecommitdiffstats
path: root/community/minuet/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/minuet/APKBUILD')
-rw-r--r--community/minuet/APKBUILD40
1 files changed, 28 insertions, 12 deletions
diff --git a/community/minuet/APKBUILD b/community/minuet/APKBUILD
index 288006ee76c..777fdc9a0c3 100644
--- a/community/minuet/APKBUILD
+++ b/community/minuet/APKBUILD
@@ -1,34 +1,50 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=minuet
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+_commit="353639d99eb54d251516a13db5032b71bd67b47c"
+arch="all !armhf" # armhf blocked by qt6-qtdeclarative
url="https://minuet.kde.org/"
pkgdesc="Minuet Music Education"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev qt5-qtsvg-dev kcoreaddons-dev ki18n-dev kcrash-dev kdoctools-dev fluidsynth-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/minuet-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ fluidsynth-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdoctools-dev
+ ki18n-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+
+ qt6-qtsvg-dev
+ samurai
+ "
subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/minuet.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/minuet-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-0513c9074c4505a0f83899b340dd122c7c5861325fa5e27b18ce11d1195069d0066b47861f8ab3eb540d3a5e89c6134cab9016680709c650a322ff4599bb35de minuet-21.04.3.tar.xz
+548ff005ce377a1aa89d4dba1435a2678dcae63d6f27cf3751f5cb57de1f80e28e825fcd7b7c0b957881364fe586d265ed57b656a7407cdd32411fabbce3aeee minuet-24.02.2.tar.xz
"