aboutsummaryrefslogtreecommitdiffstats
path: root/community/minuet/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/minuet/APKBUILD')
-rw-r--r--community/minuet/APKBUILD36
1 files changed, 26 insertions, 10 deletions
diff --git a/community/minuet/APKBUILD b/community/minuet/APKBUILD
index 2395aea99e7..777fdc9a0c3 100644
--- a/community/minuet/APKBUILD
+++ b/community/minuet/APKBUILD
@@ -1,19 +1,36 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=minuet
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+_commit="353639d99eb54d251516a13db5032b71bd67b47c"
+arch="all !armhf" # armhf blocked by qt6-qtdeclarative
url="https://minuet.kde.org/"
pkgdesc="Minuet Music Education"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev qt5-qtsvg-dev kcoreaddons-dev ki18n-dev kcrash-dev kdoctools-dev fluidsynth-dev samurai"
-source="https://download.kde.org/stable/release-service/$pkgver/src/minuet-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ fluidsynth-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdoctools-dev
+ ki18n-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+
+ qt6-qtsvg-dev
+ samurai
+ "
subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/education/minuet.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/minuet-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -21,14 +38,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-5cff0d4d0a5a5511131298b5e7f6774fb8b0b0e1217054305f7df2fe397f4f0e50086c8e5b8f45137cf83d16fe2bab2d331c12b2303e84abf42e19b3c165f692 minuet-22.04.2.tar.xz
+548ff005ce377a1aa89d4dba1435a2678dcae63d6f27cf3751f5cb57de1f80e28e825fcd7b7c0b957881364fe586d265ed57b656a7407cdd32411fabbce3aeee minuet-24.02.2.tar.xz
"