aboutsummaryrefslogtreecommitdiffstats
path: root/community/mnc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mnc/APKBUILD')
-rw-r--r--community/mnc/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/mnc/APKBUILD b/community/mnc/APKBUILD
index be4602ea73a..3780440e6b6 100644
--- a/community/mnc/APKBUILD
+++ b/community/mnc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=mnc
pkgver=0.4
-pkgrel=4
+pkgrel=20
arch="all"
url="https://git.sr.ht/~anjan/mnc"
pkgdesc="get the time in seconds to next cron job"
@@ -11,8 +11,12 @@ license="Unlicense"
makedepends="go binutils"
options="!check" # no testsuite in upstream
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+export GOFLAGS="$GOFLAGS -modcacherw"
+
build() {
- export GOFLAGS="$GOFLAGS -modcacherw"
go build mnc.go
strip mnc
}