aboutsummaryrefslogtreecommitdiffstats
path: root/community/mnc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mnc/APKBUILD')
-rw-r--r--community/mnc/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/mnc/APKBUILD b/community/mnc/APKBUILD
index bae6fbca7c6..3780440e6b6 100644
--- a/community/mnc/APKBUILD
+++ b/community/mnc/APKBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Anjandev Momi <anjan@momi.ca>
# Contributor: Maarten van Gompel <proycon@anaproy.nl>
+# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=mnc
-pkgver=0.3
-pkgrel=1
+pkgver=0.4
+pkgrel=20
arch="all"
url="https://git.sr.ht/~anjan/mnc"
pkgdesc="get the time in seconds to next cron job"
@@ -11,8 +11,12 @@ license="Unlicense"
makedepends="go binutils"
options="!check" # no testsuite in upstream
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+export GOFLAGS="$GOFLAGS -modcacherw"
+
build() {
- export GOFLAGS="$GOFLAGS -modcacherw"
go build mnc.go
strip mnc
}
@@ -22,4 +26,6 @@ package() {
install mnc "$pkgdir"/usr/bin
}
-sha512sums="09ea243928804f3de6b3b6e21eb955ba6073b853d0575d925b1951c1f7b039a4c05fb9f96dafa85cdf5f35e1a1bc2c603e03a341aa86b8e38bcd78238cfa1c23 mnc-0.3.tar.gz"
+sha512sums="
+22f6ce2a6da34ce0d70fb9e6608e1cbd14ac1dd16e38700a01c627b3ea4d43c4492db528708b9e6efc1b018ef8091434da43f3641e3f34648a68239c26bc249d mnc-0.4.tar.gz
+"