aboutsummaryrefslogtreecommitdiffstats
path: root/community/moc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/moc/APKBUILD')
-rw-r--r--community/moc/APKBUILD46
1 files changed, 30 insertions, 16 deletions
diff --git a/community/moc/APKBUILD b/community/moc/APKBUILD
index dd6ad0fa447..6dd1c0b16f9 100644
--- a/community/moc/APKBUILD
+++ b/community/moc/APKBUILD
@@ -2,28 +2,41 @@
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=moc
pkgver=2.5.2
-pkgrel=1
+pkgrel=4
pkgdesc="MOC is a console audio player"
url="http://moc.daper.net/"
arch="all"
-license="GPL"
-makedepends="curl-dev libtool file ffmpeg-dev speex-dev alsa-lib-dev
- libmodplug-dev faad2-dev jack-dev libmad-dev ncurses-dev"
+license="GPL-2.0-or-later"
+makedepends="
+ alsa-lib-dev
+ autoconf
+ curl-dev
+ faad2-dev
+ ffmpeg4-dev
+ file
+ jack-dev
+ libmad-dev
+ libmodplug-dev
+ libtool
+ ncurses-dev
+ speex-dev
+ "
subpackages="$pkgname-doc"
-# ffmpeg4.patch courtesy of Arch Linux
source="
- http://ftp.daper.net/pub/soft/moc/stable/moc-${pkgver}.tar.bz2
+ http://ftp.daper.net/pub/soft/moc/stable/moc-$pkgver.tar.bz2
ffmpeg4.patch
-"
+ fix-https.patch
+ implicit.patch
+ "
-builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
default_prepare
update_config_sub
+ autoconf
}
build() {
- cd "$builddir"
+ CFLAGS="$CFLAGS -D_GNU_SOURCE" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -44,20 +57,21 @@ build() {
--with-speex \
--with-samplerate \
--with-curl \
- --disable-cache \
- --disable-debug
+ --disable-cache
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" install
}
-sha512sums="992d06809fb52e58dcee63704bde05795b99edbac46edd8381f314c564490013b18e1853926f419c2c3c7f1bb68ff35e97048de03ace3232b800cf4b3b7dbe0f moc-2.5.2.tar.bz2
-a2af41467573b6f674be4007fda5990035513da6733030b882874dd44562b75c88c63e60c1d84a7b6522191bb4dbc38fb4e7d8462ba4add7425643dcbbf6d315 ffmpeg4.patch"
+sha512sums="
+992d06809fb52e58dcee63704bde05795b99edbac46edd8381f314c564490013b18e1853926f419c2c3c7f1bb68ff35e97048de03ace3232b800cf4b3b7dbe0f moc-2.5.2.tar.bz2
+a2af41467573b6f674be4007fda5990035513da6733030b882874dd44562b75c88c63e60c1d84a7b6522191bb4dbc38fb4e7d8462ba4add7425643dcbbf6d315 ffmpeg4.patch
+e8686c2c1050f3c41147f90488f4d264eb50f5b5d9c5fc03172bf4fd70a3220ebac147e03ab773d330c55fc4e0a20538c6724ca094003716fa448202af0782d1 fix-https.patch
+4fde528a90842a70308022413ca8978527e1358aee9c19546a69a624871f0f5b0104b4458d074b526600a287857a4e2270a7b42d8fe1cedc986b8b6d568b09fb implicit.patch
+"