aboutsummaryrefslogtreecommitdiffstats
path: root/community/modemmanager-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/modemmanager-qt/APKBUILD')
-rw-r--r--community/modemmanager-qt/APKBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/community/modemmanager-qt/APKBUILD b/community/modemmanager-qt/APKBUILD
index 8ccc9a097bb..b0f7c22da23 100644
--- a/community/modemmanager-qt/APKBUILD
+++ b/community/modemmanager-qt/APKBUILD
@@ -1,31 +1,35 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=modemmanager-qt
-pkgver=5.84.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="Qt wrapper for ModemManager DBus API"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> modemmanager
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
modemmanager-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz-dev
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # requires dbus running
+checkdepends="dbus"
+_repo_url="https://invent.kde.org/frameworks/modemmanager-qt.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/modemmanager-qt-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -33,14 +37,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ dbus-run-session -- ctest --test-dir build --output-on-failure
}
-
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-61dd3c5c0dd319fee86163e4e39356d551d49ce000c58b13e2e605be5132511c6c6464f6010ad70ab9dc3a3f28746a3d69df03746b7b9b0d170ed3bcb1b17056 modemmanager-qt-5.84.0.tar.xz
+5a90d5bb11de050dcc70c34278aee3fb4eda146f17bbb5c03a7088b7784ec3dd57328d21ba25c747b1acb2ad4edbd246040e2891515b2c40158f49d728a56702 modemmanager-qt-6.0.0.tar.xz
"