aboutsummaryrefslogtreecommitdiffstats
path: root/community/modemmanager-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/modemmanager-qt/APKBUILD')
-rw-r--r--community/modemmanager-qt/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/modemmanager-qt/APKBUILD b/community/modemmanager-qt/APKBUILD
index c3c30eeeacd..0f1373abe81 100644
--- a/community/modemmanager-qt/APKBUILD
+++ b/community/modemmanager-qt/APKBUILD
@@ -1,27 +1,30 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=modemmanager-qt
-pkgver=5.97.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Qt wrapper for ModemManager DBus API"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> modemmanager
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
modemmanager-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz-dev
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # requires dbus running
+checkdepends="dbus"
+_repo_url="https://invent.kde.org/frameworks/modemmanager-qt.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/modemmanager-qt-$pkgver.tar.xz"
build() {
@@ -34,8 +37,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ dbus-run-session -- ctest --test-dir build --output-on-failure
}
package() {
@@ -43,5 +45,5 @@ package() {
}
sha512sums="
-f776ce476233d3d2d58b9a71fa127b5cac8c84acedc0ac98ff88c3bd4e5fda89885577fc2b87764a793dc740600e10e2a37c49774c95394e64154f889ec59e6e modemmanager-qt-5.97.0.tar.xz
+d31d97802ad2f9068509e15430113c8e98803592ce801360222377b39a808055929292eaf76773253e5894813851fe0957fdd5c35743d481fc7caea1acd59648 modemmanager-qt-6.1.0.tar.xz
"