aboutsummaryrefslogtreecommitdiffstats
path: root/community/modemmanager-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/modemmanager-qt/APKBUILD')
-rw-r--r--community/modemmanager-qt/APKBUILD49
1 files changed, 28 insertions, 21 deletions
diff --git a/community/modemmanager-qt/APKBUILD b/community/modemmanager-qt/APKBUILD
index 8a2f7a7748c..0f1373abe81 100644
--- a/community/modemmanager-qt/APKBUILD
+++ b/community/modemmanager-qt/APKBUILD
@@ -1,42 +1,49 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=modemmanager-qt
-pkgver=5.66.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Qt wrapper for ModemManager DBus API"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
-depends_dev="modemmanager-dev qt5-qtbase-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen graphviz-dev qt5-qttools-dev"
+depends_dev="
+ modemmanager-dev
+ qt6-qtbase-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz-dev
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # requires dbus running
+checkdepends="dbus"
+_repo_url="https://invent.kde.org/frameworks/modemmanager-qt.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/modemmanager-qt-$pkgver.tar.xz"
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
-
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
- make
+ cmake --build build
}
check() {
- cd "$builddir"/build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ dbus-run-session -- ctest --test-dir build --output-on-failure
}
-
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="2106d09e54fa47659398116f1066e479524be34bdc62043ab3e2e0264a2402096a3b7a9025157bc747c97a40b3da77c8a5f5e66ae594040bd646d62e5cee42f4 modemmanager-qt-5.66.0.tar.xz"
+
+sha512sums="
+d31d97802ad2f9068509e15430113c8e98803592ce801360222377b39a808055929292eaf76773253e5894813851fe0957fdd5c35743d481fc7caea1acd59648 modemmanager-qt-6.1.0.tar.xz
+"