aboutsummaryrefslogtreecommitdiffstats
path: root/community/mokutil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mokutil/APKBUILD')
-rw-r--r--community/mokutil/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/mokutil/APKBUILD b/community/mokutil/APKBUILD
new file mode 100644
index 00000000000..cfda7356c8e
--- /dev/null
+++ b/community/mokutil/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Matthew T Hoare <matthew.t.hoare@gmail.com>
+# Maintainer: Matthew T Hoare <matthew.t.hoare@gmail.com>
+pkgname=mokutil
+pkgver=0.7.2
+pkgrel=0
+pkgdesc="Utility to manipulate the machine owner keys (MOK) stored in the database of shim"
+url="https://github.com/lcp/mokutil"
+arch="aarch64 armhf armv7 x86 x86_64" # Secure Boot is only available for these platforms
+license="GPL-3.0-or-later"
+makedepends="
+ autoconf
+ automake
+ efivar-dev
+ keyutils-dev
+ openssl-dev>3
+ "
+options="!check" # no tests provided
+subpackages="$pkgname-doc $pkgname-bash-completion"
+source="https://github.com/lcp/mokutil/archive/$pkgver/mokutil-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ autoreconf -f -i
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/sbin \
+ --sysconfdir=/etc
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+cdab37f86191c009b8264f065c3ca8ca051d8c1366191dca4c142d4146a0f7b7614cb17e53b6a8ca6fde0462bc113d4a1a751673b755eea0b3ed6e90da507f5a mokutil-0.7.2.tar.gz
+"