aboutsummaryrefslogtreecommitdiffstats
path: root/community/mpc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mpc/APKBUILD')
-rw-r--r--community/mpc/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/mpc/APKBUILD b/community/mpc/APKBUILD
index 5ddda925b2c..cf46dac52ac 100644
--- a/community/mpc/APKBUILD
+++ b/community/mpc/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpc
-pkgver=0.34
+pkgver=0.35
pkgrel=0
pkgdesc="Minimalist command line interface to MPD"
url="https://www.musicpd.org/clients/mpc/"
@@ -9,18 +9,17 @@ arch="all"
license="GPL-2.0-or-later"
makedepends="libmpdclient-dev py3-sphinx meson check-dev"
subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc"
-source="https://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
- 0001-doc-make-upload-target-dependency-on-rsync-optional.patch"
+source="https://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
build() {
abuild-meson \
-Dtest=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -38,6 +37,5 @@ bashcomp() {
}
sha512sums="
-d43d5547134ffb24f2a2972882f6e264c1011a94d1033369d329487f59414d32d9842835afdd05da96fd8ed28f823d2ae2f46d8d8d24b68f3695badca2a9bbb2 mpc-0.34.tar.xz
-60c00c5ab212d453f879ac391d58be4d0fb7ea97dd974ac2369463bebc2e3a05f7176f3c89328b432d84382ecee9c8e9d67e16a0eb50219aeca53675d6a5988f 0001-doc-make-upload-target-dependency-on-rsync-optional.patch
+be7ec268432eb8e34092d025e6a40379e83d54e5f87943beeb87ed8fe9db4c5c8261b09cc3230ada28300151382f97b1c2da45f54e8aad68af9946f484d0b28b mpc-0.35.tar.xz
"