aboutsummaryrefslogtreecommitdiffstats
path: root/community/mpc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mpc/APKBUILD')
-rw-r--r--community/mpc/APKBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/community/mpc/APKBUILD b/community/mpc/APKBUILD
index c30524f2f45..cc81a8fc9e8 100644
--- a/community/mpc/APKBUILD
+++ b/community/mpc/APKBUILD
@@ -2,34 +2,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpc
pkgver=0.28
-pkgrel=0
+pkgrel=1
pkgdesc="Minimalist command line interface to MPD"
url="https://www.musicpd.org/clients/mpc/"
arch="all"
license="GPL2"
-depends=""
-depends_dev=""
makedepends="libmpdclient-dev"
subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc"
-source="http://www.musicpd.org/download/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
+source="http://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+builddir="$srcdir/$pkgname-$pkgver"
-_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
bashcomp() {
@@ -39,9 +37,7 @@ bashcomp() {
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
mv "$pkgdir"/usr/share/doc/$pkgname/$pkgname-completion.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname || return 1
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
}
-md5sums="e9cfaf17ab1db54dba4df4b08aa0db3f mpc-0.28.tar.xz"
-sha256sums="a4337d06c85dc81a638821d30fce8a137a58d13d510be34a11c1cce95cabc547 mpc-0.28.tar.xz"
sha512sums="1d0c96c3c7cee2eac2d3cf25f09d74b5807b8ea56ff7dfc033b8fa690fd4d42de726a641e4f2552550d8a1c1b2840575aec5c595166ca5ae5776fcc93c8fb7cf mpc-0.28.tar.xz"