aboutsummaryrefslogtreecommitdiffstats
path: root/community/mplayer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mplayer/APKBUILD')
-rw-r--r--community/mplayer/APKBUILD74
1 files changed, 50 insertions, 24 deletions
diff --git a/community/mplayer/APKBUILD b/community/mplayer/APKBUILD
index b515ce0de7e..bca691fdc9a 100644
--- a/community/mplayer/APKBUILD
+++ b/community/mplayer/APKBUILD
@@ -1,34 +1,59 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mplayer
-pkgver=1.4.0
-pkgrel=5
-pkgdesc="A movie player for linux"
+pkgver=1.5.0_git20230717
+pkgrel=1
+# this is r38435 from svn
+# the commit in the linked repo says which svn r it is, too.
+_gitrev=8c62eea81f5959ad94de8506ec5b46f060fa237c
+pkgdesc="Movie player for linux"
url="http://www.mplayerhq.hu/design7/news.html"
-arch="x86_64 aarch64"
+arch="x86_64 aarch64 armv7"
license="GPL-2.0-or-later"
subpackages="$pkgname-doc"
-makedepends="libxxf86dga-dev libxv-dev libmad-dev lame-dev libao-dev
- libtheora-dev xvidcore-dev zlib-dev sdl2-dev freetype-dev libdvdread-dev
- x264-dev faac-dev fontconfig-dev libxvmc-dev alsa-lib-dev live-media-dev
- mesa-dev yasm libpng-dev libvdpau-dev libvpx-dev libcdio-paranoia-dev"
-
-source="http://www.mplayerhq.hu/MPlayer/releases/MPlayer-${pkgver%.*}.tar.xz
+makedepends="
+ alsa-lib-dev
+ faac-dev
+ ffmpeg-dev
+ fontconfig-dev
+ freetype-dev
+ lame-dev
+ libao-dev
+ libcdio-paranoia-dev
+ libdvdread-dev
+ libmad-dev
+ libpng-dev
+ libtheora-dev
+ libvdpau-dev
+ libxv-dev
+ libxvmc-dev
+ libxxf86dga-dev
+ mesa-dev
+ nasm
+ sdl2-dev
+ x264-dev
+ xvidcore-dev
+ zlib-dev
+ "
+source="https://dev.alpinelinux.org/archive/mplayer/mplayer-$pkgver.tar.xz
x11-libs.patch
- mplayer_alpine_aarch64.patch
"
-builddir="$srcdir"/MPlayer-${pkgver%.*}
+options="!check" # no tests
+
+snapshot() {
+ clean
+ makedepends="git xz rsync tar" deps
+ mkdir -p "$srcdir"
+ cd "$srcdir"
+ git clone --filter=tree:0 https://git.mplayerhq.hu/mplayer .
+ git archive --format tar --prefix=$pkgname-$pkgver/ $_gitrev > "$SRCDEST"/mplayer-$pkgver.tar
+ xz -vv -T0 -9 -e "$SRCDEST"/$pkgname-$pkgver.tar
+ rsync --progress -La "$SRCDEST"/$pkgname-$pkgver.tar.xz dev.alpinelinux.org:/archive/mplayer/
+}
build() {
- case "$CARCH" in
- aarch64)
- cpudetection="disable-runtime-cpudetection"
- ;;
- *)
- cpudetection="enable-runtime-cpudetection"
- esac
./configure \
--prefix=/usr \
- --$cpudetection \
+ --enable-runtime-cpudetection \
--disable-gui \
--disable-gif \
--disable-arts \
@@ -38,6 +63,7 @@ build() {
--enable-gl \
--disable-tv-v4l1 \
--enable-tv-v4l2 \
+ --disable-ffmpeg_a \
--disable-liblzo \
--disable-speex \
--disable-openal \
@@ -51,11 +77,12 @@ build() {
--enable-debug \
--enable-radio \
--enable-radio-capture \
- --extra-cflags="-I/usr/lib/live-media -O2 -fno-PIC -fno-PIE" \
+ --extra-cflags="-O2 -fno-PIC -fno-PIE" \
--extra-ldflags="-no-pie" \
--disable-nemesi \
--enable-freetype \
- --enable-xvmc
+ --enable-xvmc \
+ --yasm=nasm
make
}
@@ -66,7 +93,6 @@ package() {
}
sha512sums="
-8ef71cad187d8c8f81c837279bd3a421b440c892d3347a667670b21c954007e35cf0d15828f0901f347b9c1b053e8da4bc7f0fb6de34382d1e463074923d7b34 MPlayer-1.4.tar.xz
+bea683c452452f1bf76fd28e9ad01b4586fed5f6502c476c631f246f613ecbcc601166247623a7de83a68818b5a4b03ed92a0e839d23a5377c86d8b714427a5e mplayer-1.5.0_git20230717.tar.xz
bba012c5a116cbc6715955a0a563c89a33a1d8ad3c44301a083ce65296ba9112a88a58e38c874d9347f9c3133054e62bd16d3b3367383f207ee40ddae105081c x11-libs.patch
-7bcb79de0627903ae1016487f9623283d3b2b186c4f2e5686093558f8d9b5d884e3357a93f43862e14fc261e587c50cd38821896ae2bdaff3f32290194fa4b55 mplayer_alpine_aarch64.patch
"