aboutsummaryrefslogtreecommitdiffstats
path: root/community/mu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mu/APKBUILD')
-rw-r--r--community/mu/APKBUILD70
1 files changed, 30 insertions, 40 deletions
diff --git a/community/mu/APKBUILD b/community/mu/APKBUILD
index 5c1689b53eb..b8661979ac9 100644
--- a/community/mu/APKBUILD
+++ b/community/mu/APKBUILD
@@ -2,68 +2,58 @@
# Contributor: stef <l0ls0fo2i@ctrlc.hu>
# Contributor: Eivind Uggedal <eu@eju.no>
# Contributor: Nico Schottelius <nico.schottelius@ungleich.ch>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=mu
-pkgver=1.4.15
+pkgver=1.12.2
pkgrel=0
pkgdesc="A collection of utilities for indexing and searching Maildirs"
-# armv7 and x86 blocked by gmime
-# s390x, mips64 and riscv64 blocked by emacs
-arch="all !armv7 !x86 !s390x !mips64 !riscv64"
-url="http://www.djcbsoftware.nl/code/mu"
-license="GPL-3.0"
-depends="sqlite"
+url="https://www.djcbsoftware.nl/code/mu/"
+arch="all"
+license="GPL-3.0-or-later"
makedepends="
- autoconf
- automake
- emacs
- gettext-dev
+ emacs-nox
+ glib-dev
gmime-dev
- libtool
+ meson
+ readline-dev
texinfo
- sqlite-dev
xapian-core-dev
"
-subpackages="$pkgname-doc mu4e"
-source="$pkgname-$pkgver.tar.gz::https://github.com/djcb/mu/archive/$pkgver.tar.gz"
+subpackages="$pkgname-doc mu4e::noarch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/djcb/mu/archive/v$pkgver.tar.gz
+ mu-utils-stdout.patch
+ "
prepare() {
default_prepare
- autoreconf --force --install
+
+ abuild-meson \
+ -Dguile=disabled \
+ -Dreadline=enabled \
+ build
}
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --disable-webkit \
- --disable-gtk \
- --enable-mu4e
- make
+ ninja -C build
}
-package() {
- make DESTDIR=$pkgdir install
+check() {
+ meson test -C build
+}
- if [ -f toys/msg2pdf/msg2pdf ]; then
- install -m755 toys/msg2pdf/msg2pdf $pkgdir/usr/bin/msg2pdf
- fi
- if [ -f toys/mug/mug ]; then
- install -m755 toys/mug/mug $pkgdir/usr/bin/mug
- install -Dm644 toys/mug/mug.svg $pkgdir/usr/share/pixmaps/mug.svg
- fi
+package() {
+ DESTDIR=$pkgdir meson install -C build
}
mu4e() {
pkgdesc="Emacs-based e-mail client which uses mu as its back-end"
depends="$pkgname=$pkgver-r$pkgrel cmd:emacs"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/share "$subpkgdir"/usr
+ amove usr/share
}
-sha512sums="dd0426c1fb7fe2430b47fc1232e067d1c017b3c428bbd8012c542f6e1ffa7741bb145c6851f40cbc945403534dabb4aa99faf369166167d187f083dde1d30546 mu-1.4.15.tar.gz"
+sha512sums="
+db08e2fa46e7f12372e928264de88de08e9f6334befa63f891823880ec532ece43a3330d9c99256cf70ea73404400a2afe0f6f6e3b19f9ff04fd9aa5926c475f mu-1.12.2.tar.gz
+d3808f98b93954222731d373d96dc92f798fe78d90e6ed17a86aef7d4d010d414711bd231047e4147540f2907f016b66f6a829e0cd3126aa377aa88c669104d7 mu-utils-stdout.patch
+"