aboutsummaryrefslogtreecommitdiffstats
path: root/community/mujs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mujs/APKBUILD')
-rw-r--r--community/mujs/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/community/mujs/APKBUILD b/community/mujs/APKBUILD
index 5bef19ff1aa..eeba8e9cba3 100644
--- a/community/mujs/APKBUILD
+++ b/community/mujs/APKBUILD
@@ -1,24 +1,25 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=mujs
-pkgver=1.2.0
+pkgver=1.3.2
pkgrel=0
pkgdesc="An embeddable JavaScript interpreter"
-url="https://mujs.com"
+url="https://mujs.com/"
arch="all"
license="ISC"
makedepends="readline-dev"
subpackages="$pkgname-dev $pkgname-libs"
-source="https://mujs.com/downloads/mujs-$pkgver.tar.gz
- $pkgname-0001-160ae29.patch::https://github.com/ArtifexSoftware/mujs/commit/160ae29578054dc09fd91e5401ef040d52797e61.patch
- $pkgname-0002-910acc8.patch::https://github.com/ArtifexSoftware/mujs/commit/910acc807c3c057e1c0726160808f3a9f37b40ec.patch
- $pkgname-0003-f5b3c70.patch::https://github.com/ArtifexSoftware/mujs/commit/f5b3c703e18725e380b83427004632e744f85a6f.patch
- "
+source="https://mujs.com/downloads/mujs-$pkgver.tar.gz"
options="!check" # no tests provided
# This is based on Debian.
_sover=${pkgver#1.}; _sover=${_sover%%.*}
+# secfixes:
+# 1.3.0-r0:
+# - CVE-2022-30974
+# - CVE-2022-30975
+
build() {
export XCFLAGS=${CFLAGS/-Os/-O2}
export CPPFLAGS=${CPPFLAGS/-Os/}
@@ -41,8 +42,5 @@ package() {
}
sha512sums="
-dcde632f3be934653b7604a04c282fb71371cb416a13c186541d4fa6de8483091ddb77f06db1cd3b8c382f644f8c8ec83310611c5433aea3fcfba477ce9daf57 mujs-1.2.0.tar.gz
-a4e432fe4dada3b29abe51fe8793374aa2f402e862d59c420aef97aa429ebf4e9ca2d4bfe8ce60d29016e2557418124cfd74c4bb2348330b9eaca0d7998be6ba mujs-0001-160ae29.patch
-b17125f6c6bb8d6567bd3fa6a348795052ef91ad3db84d69fab309023e100c4f40961fbe7f806d0aa25918ec36477c7a5575bea4d48ebecbb88442404b701bac mujs-0002-910acc8.patch
-4db25b9a06144ad975832e853914a5c6d1d14503e1007d2b18ca2ae3f11ce2f04b272a63537433476ed9b948b9c006bcedac3590e6d94de6c19c5e2d920237ea mujs-0003-f5b3c70.patch
+ccffb04171f7ecec2cfa6f0e59859acc911836370a648e4c6703db174631ce316413a64ebf4b32eea3d3b09221ff01861cda91f4b1b9bebf495168f26f90daf5 mujs-1.3.2.tar.gz
"