aboutsummaryrefslogtreecommitdiffstats
path: root/community/mustache/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mustache/APKBUILD')
-rw-r--r--community/mustache/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/community/mustache/APKBUILD b/community/mustache/APKBUILD
new file mode 100644
index 00000000000..27655421cf7
--- /dev/null
+++ b/community/mustache/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Thomas Kienlen <kommander@laposte.net>
+# Maintainer: Thomas Kienlen <kommander@laposte.net>
+pkgname=mustache
+pkgver=4.1
+pkgrel=0
+pkgdesc="Mustache text templates for modern C++"
+url="https://github.com/kainjow/Mustache"
+arch="noarch" # header-only library
+license="BSL-1.0"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kainjow/Mustache/archive/v$pkgver.tar.gz"
+builddir="$srcdir/Mustache-$pkgver"
+
+check() {
+ make
+}
+
+package() {
+ install -D -m644 mustache.hpp "$pkgdir"/usr/include/mustache.hpp
+}
+
+sha512sums="
+609c876fc085d1331355ec1f0396e588edf1fb3ea6765abcd06043cc5f7288f015d6bb7fdeb560df78aab54ae8d97e934375de577b944a09c9ae93f9915e7aff mustache-4.1.tar.gz
+"