aboutsummaryrefslogtreecommitdiffstats
path: root/community/mutter/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mutter/APKBUILD')
-rw-r--r--community/mutter/APKBUILD99
1 files changed, 76 insertions, 23 deletions
diff --git a/community/mutter/APKBUILD b/community/mutter/APKBUILD
index 9da8142aadf..331a8e6d3f5 100644
--- a/community/mutter/APKBUILD
+++ b/community/mutter/APKBUILD
@@ -1,43 +1,95 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=mutter
-pkgver=41.1
+pkgver=46.0
pkgrel=0
pkgdesc="clutter-based window manager and compositor"
url="https://wiki.gnome.org/Projects/Mutter/"
-arch="all !mips64 !s390x !riscv64" # limited by gnome-settings-daemon -> rust
+arch="all !s390x" # no libei-dev for s390x
license="GPL-2.0-or-later"
-depends="xkeyboard-config zenity gsettings-desktop-schemas xwayland"
-makedepends="gnome-desktop-dev libcanberra-dev upower-dev json-glib-dev
- libxkbcommon-dev libxkbfile-dev wayland-protocols clutter-dev cogl-dev
- libgudev-dev libinput-dev gnome-common itstool libxml2-utils
- libxcomposite-dev libxdamage-dev elogind-dev meson pipewire-dev
- gnome-settings-daemon-dev libice-dev libsm-dev startup-notification-dev
- xorg-server graphene-dev"
+depends="
+ gnome-settings-daemon
+ gsettings-desktop-schemas
+ mutter-schemas
+ xkeyboard-config
+ "
+makedepends="
+ at-spi2-core-dev
+ cairo-dev
+ dbus-dev
+ elogind-dev
+ eudev-dev
+ fribidi-dev
+ gdk-pixbuf-dev
+ glib-dev
+ gnome-desktop-dev
+ gnome-settings-daemon-dev
+ gobject-introspection-dev
+ graphene-dev
+ gtk4.0-dev
+ json-glib-dev
+ lcms2-dev
+ libcanberra-dev
+ libdrm-dev
+ libei-dev
+ libgudev-dev
+ libice-dev
+ libinput-dev
+ libsm-dev
+ libwacom-dev
+ libx11-dev
+ libxau-dev
+ libxcb-dev
+ libxcomposite-dev
+ libxcursor-dev
+ libxdamage-dev
+ libxext-dev
+ libxfixes-dev
+ libxi-dev
+ libxinerama-dev
+ libxkbcommon-dev
+ libxkbfile-dev
+ libxrandr-dev
+ libxrender-dev
+ libxtst-dev
+ mesa-dev
+ meson
+ pango-dev
+ pipewire-dev
+ startup-notification-dev
+ wayland-dev
+ wayland-protocols
+ xkeyboard-config-dev
+ xwayland-dev
+ "
options="!check" # Can't be run with release builds
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-dbg"
+subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-lang $pkgname-schemas::noarch"
source="https://download.gnome.org/sources/mutter/${pkgver%.*}/mutter-$pkgver.tar.xz
- fixudev-req.patch"
-
-prepare() {
- default_prepare
- # disable test subdirs, causes looping on builders and we don't run
- # tests anyway
- sed -e '/subdir/d' -i cogl/tests/meson.build
-}
+ fixudev-req.patch
+ pcversion.patch
+ "
build() {
abuild-meson \
+ -Db_lto=true \
-Degl_device=true \
-Dudev=true \
-Dnative_backend=true \
-Dintrospection=true \
- -Dxwayland_path=/usr/bin/Xwayland \
-Dremote_desktop=true \
-Dprofiler=false \
-Dtests=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
+}
+
+schemas() {
+ pkgdesc="Mutter schemas related files"
+ depends=""
+
+ amove usr/share/glib-2.0/schemas
+ amove usr/share/GConf/gsettings
+ amove usr/share/gnome-control-center/keybindings
}
package() {
@@ -45,6 +97,7 @@ package() {
}
sha512sums="
-797f857a6cc053e3639a002bc35f8431ed55bd887189f74f7b183bf9e54319dd66910c9d165826effffb9bec05ec7454ce21e4d0a78cb1a9d841c1eb37865d4e mutter-41.1.tar.xz
-6f21171bbd0ad0fc67cbaf5fb1478b22b482a9ae33b9328cc51a5dd31bcf7d95cd41e6cbbac21d3d8801cc064a62a64ae38ed7d0501ab605b861058c32f3bc30 fixudev-req.patch
+0314183f763b609105f42233f19507eed14f9a8fab4b0985e966ab208d03a22b600e7a4ab3f6a190a5704abcea663ae1a0cf2394eb42a6c076b7a558ef51eacc mutter-46.0.tar.xz
+3e5dd59f2f2fd80edde13f64d70d52a023dec303fd8dbfa3ded0d77faf7643179f2ad74d4acd3450decb67deaf6ac85a7af5146fa96f33917b4363f884413af9 fixudev-req.patch
+670927a5528f9fec4801b7dab8a377b7280c239acb1f7a9077647deef71119738deb958a94d4ce0a99d39b29eeab3b2505698f7d19b880bbcec9f5260202d3a6 pcversion.patch
"