aboutsummaryrefslogtreecommitdiffstats
path: root/community/mxml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mxml/APKBUILD')
-rw-r--r--community/mxml/APKBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/community/mxml/APKBUILD b/community/mxml/APKBUILD
index 0014e390b4c..421f69af06e 100644
--- a/community/mxml/APKBUILD
+++ b/community/mxml/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mxml
-pkgver=3.2
+pkgver=3.3.1
pkgrel=0
pkgdesc="Small XML library that you can use to read and write XML files"
url="https://www.msweet.org/mxml/"
@@ -9,8 +9,18 @@ license="Apache-2.0"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/michaelrsweet/mxml/archive/v$pkgver.tar.gz"
+prepare() {
+ default_prepare
+
+ update_config_sub
+ update_config_guess
+}
+
build() {
- ./configure --prefix=/usr \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
@@ -27,4 +37,6 @@ package() {
rm -f "$pkgdir"/usr/lib/*.a
}
-sha512sums="ed3f2b361394ef225a708b0032976a3d191d5eaea3022e190b29e0ee140e8f998f1d65c64e4898872b169516cee44f4f5f18401c6410c3b5aa1e9680b23e8675 mxml-3.2.tar.gz"
+sha512sums="
+43e6a92806d9c3f5db39fbf960c15ebfa6d92ef98274b7ce39b57724d6c26ad4362d6d8f3c1023efda92e6a815df068e5038a0cd479562b6be9dbdda8e827a41 mxml-3.3.1.tar.gz
+"