aboutsummaryrefslogtreecommitdiffstats
path: root/community/mycli/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mycli/APKBUILD')
-rw-r--r--community/mycli/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/mycli/APKBUILD b/community/mycli/APKBUILD
new file mode 100644
index 00000000000..c307b03add7
--- /dev/null
+++ b/community/mycli/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: omni <omni+alpine@hack.org>
+pkgname=mycli
+pkgver=1.27.0
+pkgrel=0
+pkgdesc="MySQL CLI with autocompletion and syntax highlighting"
+url="https://www.mycli.net/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ python3
+ py3-pyaes
+ py3-click
+ py3-pygments
+ py3-prompt_toolkit
+ py3-pymysql
+ py3-sqlglot
+ py3-sqlparse
+ py3-configobj
+ py3-cryptography
+ py3-cli_helpers
+ py3-pyperclip
+ "
+makedepends="python3-dev py3-gpep517 py3-paramiko py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-mock"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/m/mycli/mycli-$pkgver.tar.gz"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ # click 8.1 output differs
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -v -k "not test_auto_escaped_col_names" test
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/test/
+}
+
+sha512sums="
+b382d983c8afc7ee3750e979c451da3fb4124825c595d1f02c50a945fe56be117fe540c49fce1f0dfa06fa52254febcb90598396cd0f96acc328808214201f44 mycli-1.27.0.tar.gz
+"