aboutsummaryrefslogtreecommitdiffstats
path: root/community/mycroft-core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mycroft-core/APKBUILD')
-rw-r--r--community/mycroft-core/APKBUILD93
1 files changed, 0 insertions, 93 deletions
diff --git a/community/mycroft-core/APKBUILD b/community/mycroft-core/APKBUILD
deleted file mode 100644
index 8614d35fef7..00000000000
--- a/community/mycroft-core/APKBUILD
+++ /dev/null
@@ -1,93 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=mycroft-core
-pkgver=21.2.0
-pkgrel=0
-pkgdesc="Mycroft Core, the Mycroft Artificial Intelligence platform"
-url="https://mycroft.ai/"
-# mips, mips64 and s390x blocked by py3-precise-runner
-# s390x blocked by mimic1
-arch="noarch !mips !mips64 !s390x"
-license="Apache-2.0"
-depends="
- mimic1
- mycroft-skills-kit
- mycroft-skills-manager
- py3-adapt-parser
- py3-dateutil
- py3-fann2
- py3-fasteners
- py3-gtts
- py3-inflection
- py3-lingua-franca
- py3-mycroft-messagebus-client
- py3-padaos
- py3-padatious
- py3-petact
- py3-pillow
- py3-pocketsphinx
- py3-precise-runner
- py3-psutil
- py3-pyaudio
- py3-pyee
- py3-requests
- py3-requests-futures
- py3-serial
- py3-speechrecognition
- py3-tornado
- py3-websocket-client
- py3-xdg
- py3-yaml
- python3
- "
-# These dependencies are required to play audio with the local backend
-# mpg123: mpg123
-# pulseaudio-utils: paplay
-# vorbis-tools: ogg123
-depends="$depends
- mpg123
- pulseaudio-utils
- vorbis-tools
- "
-makedepends="py3-setuptools"
-checkdepends="
- py3-pytest
- py3-vlc
- py3-wheel
- "
-install="$pkgname.post-install"
-source="$pkgname-$pkgver.tar.gz::https://github.com/MycroftAI/mycroft-core/archive/release/v$pkgver.tar.gz
- profile.sh
- 0001-Upgrade-websocket-client-to-0.58.0.patch
- 0002-xdg-settings-cache-and-runtime-data.patch
- 0003-system-wide-setups.patch
- 0004-skills-from-xdg.patch
- "
-# Net is required for tests
-# Some tests are broken still, will be enabled later
-options="!check"
-builddir="$srcdir/mycroft-core-release-v$pkgver"
-
-build() {
- MYCROFT_LOOSE_REQUIREMENTS=1 python3 setup.py build
-}
-
-check() {
- # test_hotword_factory and test_local_recognizer fail
- # https://github.com/MycroftAI/mycroft-core/issues/2574
- PYTHONPATH="$PWD/build/lib" pytest -rRxs -k 'not testInvalid and not testListenerConfig'
-}
-
-package() {
- MYCROFT_LOOSE_REQUIREMENTS=1 python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- install -Dm644 "$srcdir"/profile.sh "$pkgdir"/etc/profile.d/mycroft.sh
-}
-sha512sums="
-3ff4134ba5f6425a6364b69469203ab1ca8efd034fce8edaf3161d2f35a831e7781fbbd621b28f4a88e264bd7a82371f23ac6a7cabde8504431b7e4216ac1227 mycroft-core-21.2.0.tar.gz
-c3d1a605a0b574c8e2c4031f592bdbf023f5ed9b2e1ba0cea38cf79278331f245dbe4e220e7f81de73fe612ffd722253805058dae04ba89c3d01c361b329e4ef profile.sh
-09ee45cf4e4ce8d0ba4a6ab0f2c7caef0e54748531e26adfbb3476bd5a54358fcb22b39dd28f1a9123d8ba7ada652e5d965fee54ea51a0e8f0f80e08704ee421 0001-Upgrade-websocket-client-to-0.58.0.patch
-85731166b20afc370f67482c78cea5ad3d1d25a76352aca11fba0c34470a5e71e71ccaffd867406744149210d6d9d40cd96d10114398d6d6eaf515c2d3765075 0002-xdg-settings-cache-and-runtime-data.patch
-1e938d934144d530ac410431078ff14ced545e85de3a4eaae15c5269169a8ad46224fb309d3fb167895fd4d65e4e2e8bf82795710bc30813292a1dec4f0b1777 0003-system-wide-setups.patch
-34c143ce023eb4f99a7d767191de9a91870983a7f2256aa1db208a5728fd7b751de55a6d20d77327d95c951d4ac58fbf63c7d40ca46417c481f9242465bb17a7 0004-skills-from-xdg.patch
-"