aboutsummaryrefslogtreecommitdiffstats
path: root/community/mycroft-core/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mycroft-core/APKBUILD')
-rw-r--r--community/mycroft-core/APKBUILD94
1 files changed, 0 insertions, 94 deletions
diff --git a/community/mycroft-core/APKBUILD b/community/mycroft-core/APKBUILD
deleted file mode 100644
index 3453d978ef0..00000000000
--- a/community/mycroft-core/APKBUILD
+++ /dev/null
@@ -1,94 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=mycroft-core
-pkgver=20.8.1
-pkgrel=0
-pkgdesc="Mycroft Core, the Mycroft Artificial Intelligence platform"
-url="https://mycroft.ai/"
-# mips, mips64 and s390x blocked by py3-precise-runner
-# s390x blocked by mimic1
-arch="noarch !mips !mips64 !s390x"
-license="Apache-2.0"
-depends="
- mimic1
- mycroft-skills-kit
- mycroft-skills-manager
- py3-adapt-parser
- py3-dateutil
- py3-fann2
- py3-fasteners
- py3-gtts
- py3-inflection
- py3-lingua-franca
- py3-padaos
- py3-padatious
- py3-petact
- py3-pillow
- py3-pocketsphinx
- py3-precise-runner
- py3-psutil
- py3-pyaudio
- py3-pyee
- py3-requests
- py3-requests-futures
- py3-serial
- py3-speechrecognition
- py3-tornado
- py3-websocket-client
- py3-xdg
- py3-yaml
- python3
- "
-# These dependencies are required to play audio with the local backend
-# mpg123: mpg123
-# pulseaudio-utils: paplay
-# vorbis-tools: ogg123
-depends="$depends
- mpg123
- pulseaudio-utils
- vorbis-tools
- "
-# Minimum skills required for functionality
-depends="$depends
- mycroft-skill-configuration
- mycroft-skill-fallback-unknown
- mycroft-skill-pairing
- "
-makedepends="py3-setuptools"
-checkdepends="
- py3-pytest
- py3-vlc
- py3-wheel
- "
-install="$pkgname.post-install"
-source="$pkgname-$pkgver.tar.gz::https://github.com/MycroftAI/mycroft-core/archive/release/v$pkgver.tar.gz
- profile.sh
- 0001-xdg-settings-cache-and-runtime-data.patch
- 0002-system-wide-setups.patch
- 0003-skills-from-xdg.patch
- "
-# Net is required for tests
-# Some tests are broken still, will be enabled later
-options="!check"
-builddir="$srcdir/mycroft-core-release-v$pkgver"
-
-build() {
- MYCROFT_LOOSE_REQUIREMENTS=1 python3 setup.py build
-}
-
-check() {
- # test_hotword_factory and test_local_recognizer fail
- # https://github.com/MycroftAI/mycroft-core/issues/2574
- PYTHONPATH="$PWD/build/lib" pytest -rRxs -k 'not testInvalid and not testListenerConfig'
-}
-
-package() {
- MYCROFT_LOOSE_REQUIREMENTS=1 python3 setup.py install --prefix=/usr --root="$pkgdir"
-
- install -Dm644 "$srcdir"/profile.sh "$pkgdir"/etc/profile.d/mycroft.sh
-}
-sha512sums="34d32e671f206d6d9fc3be97acc6a50f09363c9e9d04a503738b89b7b8f395728227ae30bcfdf5995835b000714b7f71b35caca8fc3290c8dca961d4aa9b2652 mycroft-core-20.8.1.tar.gz
-c3d1a605a0b574c8e2c4031f592bdbf023f5ed9b2e1ba0cea38cf79278331f245dbe4e220e7f81de73fe612ffd722253805058dae04ba89c3d01c361b329e4ef profile.sh
-44c387672fe495ec9d44d873f997142f4938a12770a9072e3283692df5de408543f9f1dac89ae0e3cfdc3f0374ad982ea6d4983d5f3b74c71dd21362e8b16893 0001-xdg-settings-cache-and-runtime-data.patch
-b9c72bb62cdc91c912f8c3ac11990c760d7892678683165607b68195e237cd43d2e9c5df1d9385b9214c7f0012c3fad5b72fd68c415a76ead0ddc16a9226ccd4 0002-system-wide-setups.patch
-4a7ce033538cbe0aff4abd9039196e166fd210560ae7bba1856701780ab6bf27d8040c4d668f1c61794974c991e18b5941989fdd6792d741ab6869bb559cc219 0003-skills-from-xdg.patch"