aboutsummaryrefslogtreecommitdiffstats
path: root/community/mycroft-gui/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mycroft-gui/APKBUILD')
-rw-r--r--community/mycroft-gui/APKBUILD37
1 files changed, 20 insertions, 17 deletions
diff --git a/community/mycroft-gui/APKBUILD b/community/mycroft-gui/APKBUILD
index a1fd5e8f64c..a8d066f77d7 100644
--- a/community/mycroft-gui/APKBUILD
+++ b/community/mycroft-gui/APKBUILD
@@ -1,33 +1,36 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=mycroft-gui
-pkgver=1.0.1
-pkgrel=1
+# It's not actually 1.0.2 but the last few tags have had no proper version numbers in them
+# We're honestly just guessing here
+pkgver=1.0.2
+pkgrel=0
pkgdesc="The Graphical User Interface used by the Mycroft Mark II and more"
url="https://mycroft.ai"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine -> qt5-qtwebview
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine -> qt5-qtwebview
+# armv7: tests segfault
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
license="Apache-2.0"
depends="kirigami2"
makedepends="
extra-cmake-modules
- kdbusaddons-dev
- kio-dev
- plasma-framework-dev
+ kdbusaddons5-dev
+ kio5-dev
+ plasma-framework5-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ qt5-qtmultimedia-dev
qt5-qtwebsockets-dev
qt5-qtwebview-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://github.com/MycroftAI/mycroft-gui/archive/v$pkgver/mycroft-gui-v$pkgver.tar.gz
- 0001-start-stop-commands-from-environment.patch
- 0002-fix-mycroft-gui-core-loader-and-stop.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/MycroftAI/mycroft-gui/archive/refs/tags/backports-stable-qt5.tar.gz"
+builddir="$srcdir/$pkgname-backports-stable-qt5"
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -36,14 +39,14 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ # -j1 to make stresstest work
+ xvfb-run ctest --test-dir build --output-on-failure -j1
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="3177f0defd653771874b4f94a05abd1047e056a3f70a24a0e47aaa4f4155f88d3a0088715a731c20adf05db5bdcc630e2965388880d72c61d617ff3c1fde1448 mycroft-gui-v1.0.1.tar.gz
-44131e11fa059e16272877ba53725ed3514a86252dbd453537703a4dbe55db233ac06ebc16692f3fd4f5d82fbcb51af0d19153445fb3f2ce6c50af3a55a1c1de 0001-start-stop-commands-from-environment.patch
-1010f7a4701c845d05f476669e4956293d1bb6396102c81f14e3bb15ec5845061b5196ab4d18f765b337323d01ee53d993b504710e89a2cabba99c8689d64a9e 0002-fix-mycroft-gui-core-loader-and-stop.patch"
+sha512sums="
+dac1b43d7eb88f7b0b843dce5c8401c092d73de83f25d4489a641d469d771b98cda862b29642fbcc06c11b750aced573ffd267318064470287c42d04f1e78fd5 mycroft-gui-1.0.2.tar.gz
+"