aboutsummaryrefslogtreecommitdiffstats
path: root/community/mycroft-plasmoid/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mycroft-plasmoid/APKBUILD')
-rw-r--r--community/mycroft-plasmoid/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/mycroft-plasmoid/APKBUILD b/community/mycroft-plasmoid/APKBUILD
index 7aaeec32466..530c2ce46ce 100644
--- a/community/mycroft-plasmoid/APKBUILD
+++ b/community/mycroft-plasmoid/APKBUILD
@@ -1,24 +1,24 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=mycroft-plasmoid
-pkgver=0_git20210201
-pkgrel=0
-_commit="70f84636da63b00d114747e440e4a15aa7d5b019"
+pkgver=0_git20230618
+pkgrel=1
+_commit="18f1acca356f8b8ca64a6b10ab89f91f93341a97"
pkgdesc="Plasma integration of different Mycroft AI services"
url="https://invent.kde.org/utilities/mycroft-plasmoid"
-# ppc64le, s390x, armhf, mips and mips64 blocked by mycroft-gui
-# riscv64 disabled due to missing rust in recursive dependency
-arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64"
+# ppc64le, s390x, riscv64, armhf and armv7 blocked by mycroft-gui
+arch="all !ppc64le !s390x !armhf !riscv64 !armv7"
license="Apache-2.0 AND LGPL-2.0-or-later AND LicenseRef-KDE-Accepted-GPL"
depends="mycroft-gui"
makedepends="
extra-cmake-modules
- ki18n-dev
- knotifications-dev
- plasma-framework-dev
+ ki18n5-dev
+ knotifications5-dev
+ plasma-framework5-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtwebsockets-dev
+ samurai
"
source="https://invent.kde.org/utilities/mycroft-plasmoid/-/archive/$_commit/mycroft-plasmoid-$_commit.tar.gz"
options="!check" # No tests
@@ -28,8 +28,8 @@ provides="plasma-mycroft=$pkgver-r$pkgrel" # Backwards compatibility
replaces="plasma-mycroft" # Backwards compatibility
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -42,4 +42,6 @@ package() {
rm "$pkgdir"/etc/mycroft/mycroft.conf
}
-sha512sums="4fc85294941ec07e852500e0cc12309f925d6fbb42be5057b9bc288428d9fc8b0cc90220c76910b4da177cf9e18d4971af0626865a718ddb3eb97abdf30f8e72 mycroft-plasmoid-70f84636da63b00d114747e440e4a15aa7d5b019.tar.gz"
+sha512sums="
+0dddffb61b3bc64256e5a722f87875e176e6d06bf5b7fbd9ea3de148d3b0589a987a092ff41830bd7cb043f427ca4549b174c44eb4c805e4492bc1bfb45d6fc8 mycroft-plasmoid-18f1acca356f8b8ca64a6b10ab89f91f93341a97.tar.gz
+"