aboutsummaryrefslogtreecommitdiffstats
path: root/community/mythes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/mythes/APKBUILD')
-rw-r--r--community/mythes/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/mythes/APKBUILD b/community/mythes/APKBUILD
index be745e52511..6a10eee4044 100644
--- a/community/mythes/APKBUILD
+++ b/community/mythes/APKBUILD
@@ -2,19 +2,24 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=mythes
pkgver=1.2.4
-pkgrel=1
+pkgrel=3
pkgdesc="A simple thesaurus"
-url="http://hunspell.sourceforge.net/"
+url="https://hunspell.sourceforge.net/"
arch="all"
license="GPL-2.0-or-later LGPL-2.0-or-later MPL-1.1"
subpackages="$pkgname-dev"
depends_dev="perl hunspell-dev"
makedepends="$depends_dev"
source="https://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+
+ update_config_sub
+ update_config_guess
+}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,15 +31,13 @@ build() {
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}
dev() {
default_dev
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+ amove usr/bin
}
sha512sums="a04da39812bcfb1391a2cba7de73e955eafe141679ec03ed6657d03bebf360b432480d0037dff9ed72a1dfda5a70d77d44ac2bb14cdb109fd8e2a38376feee21 mythes-1.2.4.tar.gz"