aboutsummaryrefslogtreecommitdiffstats
path: root/community/nautilus/meson-fix-mixed-list.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/nautilus/meson-fix-mixed-list.patch')
-rw-r--r--community/nautilus/meson-fix-mixed-list.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/nautilus/meson-fix-mixed-list.patch b/community/nautilus/meson-fix-mixed-list.patch
new file mode 100644
index 00000000000..33965043cad
--- /dev/null
+++ b/community/nautilus/meson-fix-mixed-list.patch
@@ -0,0 +1,28 @@
+Description: meson 0.58 requires the env list to be flat, it's no longer
+allowed to mix lists with scalar items.
+diff --git a/test/automated/displayless/meson.build b/test/automated/displayless/meson.build
+index 64b23bd..d7cf5db 100644
+--- a/test/automated/displayless/meson.build
++++ b/test/automated/displayless/meson.build
+@@ -45,8 +45,8 @@ foreach t: tests
+ test(
+ t[0],
+ executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep),
+- env: [
+- test_env,
++ env: test_env +
++ [
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+ ],
+@@ -64,8 +64,8 @@ foreach t: tracker_tests
+ t[0],
+ tracker_sandbox,
+ args: ['--store-tmpdir', '--index-recursive-tmpdir', test_exe],
+- env: [
+- test_env,
++ env: test_env +
++ [
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+ ],