aboutsummaryrefslogtreecommitdiffstats
path: root/community/ncmpc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ncmpc/APKBUILD')
-rw-r--r--community/ncmpc/APKBUILD37
1 files changed, 16 insertions, 21 deletions
diff --git a/community/ncmpc/APKBUILD b/community/ncmpc/APKBUILD
index c5f34eb8ff6..00e8c3c45d8 100644
--- a/community/ncmpc/APKBUILD
+++ b/community/ncmpc/APKBUILD
@@ -2,46 +2,41 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=ncmpc
-pkgver=0.35
-pkgrel=0
+pkgver=0.49
+pkgrel=1
pkgdesc="Ncurses client for the Music Player Daemon (MPD)"
url="https://www.musicpd.org/clients/ncmpc"
arch="all"
license="GPL-2.0-or-later"
-makedepends="glib-dev libmpdclient-dev meson ncurses-dev py3-sphinx boost-dev"
+makedepends="glib-dev libmpdclient-dev meson ncurses-dev py3-sphinx
+ lirc-dev pcre2-dev"
subpackages="$pkgname-doc $pkgname-lang $pkgname-dbg"
-source="https://www.musicpd.org/download/$pkgname/0/$pkgname-$pkgver.tar.xz
- doc-py3.patch
- "
+source="https://www.musicpd.org/download/ncmpc/0/ncmpc-$pkgver.tar.xz"
build() {
- LDFLAGS="$LDFLAGS -lintl" meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --buildtype=release \
- -Dlirc=disabled \
+ LDFLAGS="$LDFLAGS -lintl" \
+ abuild-meson \
+ -Dlirc=enabled \
-Dcurses=ncurses \
-Dlyrics_screen=true \
- -Dlyrics_plugin_dir=share/$pkgname/lyrics \
+ -Dlyrics_plugin_dir=/usr/share/$pkgname/lyrics \
+ -Dhtml_manual=false \
. output
- ninja -C output
+ meson compile -C output
}
check() {
- ./output/ncmpc --help > /dev/null
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
mkdir -p "$pkgdir"/usr/share/$pkgname/lyrics
install -m755 lyrics/* \
"$pkgdir"/usr/share/$pkgname/lyrics
-
- # Remove HTML documentation
- rm -rf "$pkgdir"/usr/share/doc/$pkgname/html
}
-sha512sums="64f56730b0439c23c4a833d3b65da769d5123a1613a6b565201698b753e8196375387e46b1984825c47928a0fc11ba5d9121c8c391d8b063508ed56985d32084 ncmpc-0.35.tar.xz
-de2f4ed40c72047e535b97a7a4ae57d36e15bab167a1724e636628e1a55134c128e1e13d5bc12d3223d095f8d91e966aa660af70004312b58e6d040b8914ba8e doc-py3.patch"
+sha512sums="
+9913f08d90b229af59c8da0ac737445661dc69f0174f996dedbd0c9d9c4833004dbd9319f6bc08dc8b35a191ae167c090a3f31b43167e1918c5fad8f044a4c17 ncmpc-0.49.tar.xz
+"