aboutsummaryrefslogtreecommitdiffstats
path: root/community/ncspot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ncspot/APKBUILD')
-rw-r--r--community/ncspot/APKBUILD39
1 files changed, 20 insertions, 19 deletions
diff --git a/community/ncspot/APKBUILD b/community/ncspot/APKBUILD
index ace49072611..3fc836426f5 100644
--- a/community/ncspot/APKBUILD
+++ b/community/ncspot/APKBUILD
@@ -1,42 +1,43 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ncspot
-pkgver=0.9.8
+pkgver=0.13.4
pkgrel=0
pkgdesc="Cross-platform ncurses Spotify client inspired by ncmpc and the likes"
url="https://github.com/hrkfdn/ncspot"
-# ppc64le: fails to build ring crate
-# others: limited by rust/cargo
-arch="aarch64 armhf armv7 x86 x86_64"
+# riscv64: takes eternity to build
+# s390x: fails to build nix crate
+arch="all !riscv64 !s390x"
license="BSD-2-Clause"
makedepends="
cargo
- dbus-dev
+ cargo-auditable
libxcb-dev
ncurses-dev
- openssl-dev
+ openssl-dev>3
pulseaudio-dev
python3
"
-source="https://github.com/hrkfdn/ncspot/archive/v$pkgver/ncspot-$pkgver.tar.gz"
+source="https://github.com/hrkfdn/ncspot/archive/v$pkgver/ncspot-$pkgver.tar.gz
+ no-rustls.patch
+ "
options="!check" # there's only one unit test (in v0.8.1)
-# Optimize binary for size (18 MiB -> 8.2 MiB in v0.8.1).
-export CARGO_PROFILE_RELEASE_CODEGEN_UNITS=1
-export CARGO_PROFILE_RELEASE_LTO="true"
-export CARGO_PROFILE_RELEASE_OPT_LEVEL="s"
-export CARGO_PROFILE_RELEASE_PANIC="abort"
-
-_cargo_opts='--frozen --features cover,share_selection'
+# Build with ncurses_backend instead of termion_backend, enable cover and share_selection.
+_cargo_opts="
+ --frozen
+ --no-default-features
+ --features share_clipboard,pulseaudio_backend,mpris,notify,cover,share_selection,ncurses_backend
+ "
prepare() {
default_prepare
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build $_cargo_opts --release
+ cargo auditable build $_cargo_opts --release
}
check() {
@@ -44,10 +45,10 @@ check() {
}
package() {
- cargo install $_cargo_opts --offline --path . --root="$pkgdir/usr"
- rm "$pkgdir"/usr/.crates*
+ install -D -m755 target/release/$pkgname -t "$pkgdir"/usr/bin/
}
sha512sums="
-f6c9548c236c147154e2be9e3df35407a9fff78ffce8c5e5d46064b27c7d28a1ca436c72e64a384244cfc01d127bcfbd1f80c272ce6dfa6dbff9093d76addb91 ncspot-0.9.8.tar.gz
+af869a6c011a2fe9877027aa0765b361b781292521db325932e04a7fab8a9cc9d805835ea484b82f11e756687a3b0fb2978c315cbd1da9c98c9ce8e86c85cb11 ncspot-0.13.4.tar.gz
+acb170156bd74277461d403ab6467b534c727b7e1e38df5ea0e1103333a51264b7134eee41b879d4bc9f37319e6b602de14814349c735dce7c24732a0d75dcc2 no-rustls.patch
"